EEschema refdes & value automagically moves [solved]

As of late, I’ve noticed that some symbols have ‘changed’ the placement of reference designators and value text. Resistors used to have the value inside the resistor, but now the text is outside of the resistor. Same goes for capacitors, TL0xx opamps and some other parts.

At first I thought the libraries were updated, but when opening the component in the editor, it shows the placement of the refdes and value still in the expected position.

Apparantly, this has nothing to do with them being default libraries, because I’ve made some custom symbols, and they exhibit the same, odd, problem. See the image below: on the left is the symbol when I’ve placed it on the schematic, and on the right is the preview from the component selection dialog. The latter shows it as it is in the editor with the expected text placement, but as soon as I select the component, in a fraction of a second I can see the text being moved to the position as shown on the left.


I’m currently running BZR 6458, but I seem to recall that this change suddenly happened without updating KiCad. From what I can tell from inspecting the symbol in a text editor, the text ought to be in the correct position. I’d be happy to provide any additional info required to solve this quirk. It’s quite annoying :wink:

Edit: here’s what happens with default symbols. The resistor text is rotated and moved, for the capacitor the rotation is correct, but the text ought to be just over/under the plates, and the opamp ought to have the text, say, between pins 7 and 6.


Thank you Joan, that appears to be the culprit! Unchecking the ‘automatically place component fields’ box solved my problem.

It seems that I ‘now’ have a different menu (I recall reading about reformatting the layout on the dev mailing list), so perhaps the check was (re)introduced after some update.