Eeschema only wants to print black background

Ok I’m a newb with KiCad 5.1.0 but so far the schematic editor is great. So I went to print out my schemo and the background in the print preview is black. On screen it’s set to white. ?? So I set background to black and it STILL comes out black in the print preview. Now before I go risk gumming up my laser printer with a load of toner is it the preview that’s borked or is printing completely bodged up? OS is Ubuntu 18.04 and I’m trying to print to either PDF or Laserjet 4000. Both come up black all the time no matter what I set the color to. ???

OK, seems it’s just the preview that’s at issue. Saved the file as a PDF and output is fine there. Also have checked the box “print in black and white only”. Be nice to have preview working though…

Just had a peek and the Printer Preview looks black:

My latest toner refill costed EUR5, so I don’t mind too much about the toner and printed anyway (after selecting my Samsung ML-1610, B&W only, paper size to A4).
The print on paper is all right. Just white background with black lines and text.

Seems like this may be a bug in the print preview in KiCad.

Application: kicad
Version: 5.1.0+dfsg1-1, release build
wxWidgets 3.0.4
libcurl/7.64.0 OpenSSL/1.1.1b zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.36.0 librtmp/2.3
Platform: Linux 4.19.0-4-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.67.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.64.0
Compiler: Clang 7.0.1 with C++ ABI 1002

Build settings:

Known issue with GTK3 ( Haven’t tracked down why just yet…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.