Eeschema libraries


#1

Hi there!! I just downloaded KiCad v4.0.7 but no libraries found when opening Eschema.
Of course same thing when opening Pcbnew, but in this case problem could solve with “Footprints Libraries Wizard” (No similar tool for Eeschema).

So… Any idea for adding libraries in Eeschema?? (i also downloaded “library-repos-install.sh” and “library-repos-install.bat” but i don’t know what i have to do with them.

Many thanks!!!


#2

I don’t think 4.0.7 is already officially released. The only platform that has 4.0.7 is ubuntu. Ubuntu has a separate package for the library. So install this package and you should find libs under /usr/share/kicad/library.

If this libs are not added to your project add them via eeschema->preferences->component libraries.

A lot of the libs that should be installed are not automatically added to new projects. This can be changed by edditing the main template found under /usr/share/kicad/template/kicad.pro

More details about that:


#3

Thanks for answering Rene_Poschi. I’ve installed library package (“library-repos-install.sh”) but still doesn’t work. In fact, i’ve entered in /usr/share/kicad but no exist directory named “library” there, just two directories named “scripting” and “template”. Am i doing something wrong?

The problem is in Eschema, because i can normally run CvPcb and no libraries problem. I have all footprints there (but no schematics symbols in Eeschema, i can’t do any schematic because of this).

Anyone knows why? Thanks a lot!!


#4

Are you using ubuntu or are you running a different linux distribution? (I assumed ubuntu because as far as i know only ubuntu has a 4.0.7 package) Or are you on Mac or windows. We need this details to help you. Every operating system is different!

The library install script only downloads pretty repos. (only footprints not symbols or 3d models.)
I’m not even sure it adds the downloaded footprints to the fp-lib-table. I think that would need to be done by the user. (I would suggest you follow the how to install local foootprint libs tutorial by @bobc instead of using an sh script.)

In a lot of linux distributions the symbol and 3d model library is a separate package. Use the package manager (apt under ubuntu) to install this package. I am not sure of the name of this package in any distribution. (I run fedora and simply run dnf install kicad*)
Footprints by default are added using the github plugin. (Downloaded everytime kicad needs any footprint.)

If you distro really does not have a package for the symbol and 3d model library, you can download the kicad-library repo and manually move its contents to the correct location. But i doubt this is necessary under any operating system.


#5

This doesn’t sound like the Ubuntu PPA “4.0.7”, which I call a beta


#6

SOLVED!!! Thank you very much Rene_Poschi. Finally i’ve just downloaded kicad-library and move its contents to /usr/share/kicad. So now i can start using Eschema and also run CvPcb in order to associate footprints.

Thank you very very much!