Eeschema has suddenly stopped opening, Windows 10

Hi, I am an experienced user of KiCad, using it every day. I use 5.1.6 x64 on Windows 10.

KiCad has suddenly started crashing whenever I open Eeschema. The Eeschema Icon flashes and after about 10 seconds KiCAD closes. I have tried re installing it but it’s just the same. I have tried multiple projects and all behave the same way.

Has anyone else seen this ? I have a fully up to date Windows 10 with the latest updates and all was working fine till about mid afternoon.

Thanks for any ideas or help anyone can give me.

Cheers,
Dirk

Mmm never seen something like this, but you could try:

  1. Deleting the user folder (%APPDATA%/kicad), maybe on reinstalling this folder did not got removed .
  2. Try using fallback mode instead of accelerated mode (you could have got updated, new drivers or so)
  3. Try running kicad (or eeschma) directly from the console, maybe you get to see an error message.

Hope this helps

1 Like

Please make a copy of your user folder rather than deleting it. Move it to your desktop and allow KiCad to re-initialize itself.

If this fixes it, please submit the configuration folder as a zip file to the issue tracker

Do you have an autosave file?
See this bug, fixed for what will be 5.1.7
https://gitlab.com/kicad/code/kicad/-/issues/5068

1 Like

Thank you so much for the prompt help

Removing the (%APPDATA%/kicad) folder and restarting fixed the problem. I have saved it and will submit it to the issue tracker.

Once again, many thanks.

1 Like