Eeschema does not show circles on open pins in Kicad-nightly V6.0.0-rc1 [solved]

In KiCad V5.1.x all open pins have a small circle in the schematic (upper left), while in KiCad-nithtly V6.0.0-rc1 (Lower Right) these are not shown.
Is this intentional or a bug?
Could this be a user setting?
I much prefer these circles, as an indication that there is still work to be done on the schematic. Especially as long as Eeschema relies on the matching of endpoints between wires and pins. Without these circles, there is no indication when for example a “No Connect Flag” is placed close to a pin (but not connected).

Application: KiCad Schematic Editor

Version: 6.0.0-rc1-unknown-92c732d3d9~144~ubuntu20.04.1, release build

	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-91-generic x86_64, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: Dec  6 2021 21:06:51
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.5.2
	Curl: 7.68.0
	ngspice: 31
	Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:

They are there on my Windows install from a few days ago

Should be fixed in tomorrow’s nightly, see discussion further down in the comments here:

It works OK for me. Maybe the error got in very recently?


Application: KiCad Schematic Editor (64-bit)

Version: (6.0.0-rc1-119-g126563c839), release build

wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19043), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Nov 22 2021 12:00:10
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.78.0-DEV
ngspice: 35
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

It seems to be fixed again. Probably by the issue linked to by gkeeth.

The issue I linked shows the whole history of this bug, from when it was introduced while fixing the issue’s original bug, to when Jeff fixed it :slight_smile:

The strange thing about the bug report example: If the wire in question is not connected, why do we see a junction dot? This question is probably moot if the issue is being (or has been) fixed. But to me it seems that the dot is more than just hiding something; it is lying.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.