EEschema displays the wrong version of a symbol


#1

Hello!

I run KiCad 4.0.2 on lubuntu 16.04 LTS

When I modify a symbol in my library,
then the old obsolete version is displayed in EEscema.

The symbol is modified by the library editor,
and correctly saved and also visible with the library editor.
But when I try in EEschema to place this symbol,
it is the new version up to the moment I click placing it.
In that moment the symbol is surprisingly the old obsolete
version of that symbol.
I could not find out how to force EEschema to place the
actual symbol as it is in the library, and not that obsolete version.

This phenomenon does not happen. if the new version of the
symbol is created with a new name.
But changing a symbol while keeping the name seems
not possible.
I wonder even where that obsolete symbol is stored,
as it is not existing in the library.

Best regards


#2

In eeschema of kicad 4.0.x symbol names must be unique over all libs. Otherwise you must take care of library priority.
More details see: Any conflict with names of modules and libraries?

This will be solved in kicad 5.x


#3

Hello!

Changing the priority solved my problem.

Thanks!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.