Eeschema crashed with 'PARSE_ERROR'(SOLVED)


#1

Hi,
I can’t add any component to schematic. When i trying to add component the ‘Choose component’ dialog appeared and progress bar in this dialog indicates progress of loading libraries and components. At ending of progress bar filling eeschama crashed with error: terminate called after throwing an instance of ‘PARSE_ERROR’.

I’m using KDE Neon 5.10.3 with KiCAD (version 201707101849+2a301d5~58) and kicad-library (version 201707110749+1349) installed from http://ppa.launchpad.net/js-reynaud/ppa-kicad/ubuntu.

Regards.


#2

There seems to be a problem with the connectors_molex lib.
We are not yet sure what problem exactly because it does only occur while the lib is added with the github plugin not if you download the repo itself and add it as a local lib.

(Github issue](https://github.com/KiCad/Connectors_Molex.pretty/issues/43]

Duplicate problem reported on this forum:


#3

fix committed. There is an error with the 3d path of one component.


#4

Thanks for reply. I solved the problem by installing the stable release of KiCAD (4.0.6).


#5

Nope that did solve nothing. Had i not corrected the offending footprint, you would still see the same problem. (In other words: correlation does not always mean causation.)


#6

I was try to edit same shematic (same project) on other PC and I was able to add new component (eeshematic wasn’t crashes). But on this PC installed my own version of deb-package of kicad-library. This package based on github checkout at 30 june 2017. Thus I can conclude that the problem arose after the update kicad-library on my laptop to 201707110749 version.

This temporary solve the problem in my case, because older versions of kicad-library doesn’t contains errors as I think.
And thanks for fix footprint I have installed last nightly build and all works fine.


#7

The footprint lib does not come from the kicad version. You get it directly from github. (kicad updates the footprints automatically each time it needs them. One of this time instances is opening cvpcb. This is why kicad crashed when opening cvpcb.)

In the time it took you to update kicad we fixed the underlying problem.

To test this, simply clone the lib repo and checkout the commit before the fix, and point your fp-lib-table to that version of the lib. You will find that the footprint triggered the error in all versions of kicad (you might need to point kicad to this local copy before switching to the defect commit to get the same behavior. Kicad checks new libs that are added to the fp-lib-table and does not allow you to add invalid libs.)


#8

No, footprints is part of ‘kicad-library’ deb-package from repository http://ppa.launchpad.net/js-reynaud/ppa-kicad/ubuntu.
KiCAD itself hasn’t sufficient access rights to store or replace files in directory in which this package installs libs and footprints files (directory is /usr/share/kicad).

When I couldn’t edit schematic with eeshema (due crashes after update ‘kicad-library’ package) I did edit pcb based on this schematic in cvpcb without any problems. Only eeschema was crashed, cvpcb not. Maybe when working with cvpcb it doesn’t trying to load problem footprint file.


#9

That is only true for 3d models and symbols. footprints are not on your local machine. They are downloaded into some temporary storage (i don’t know where) iff they are needed. (Via the github api)
Have a look in /usr/share/kicad/modules. This directory is empty! (exept from the packages3d directory which holds the 3d models.

This inconsistency is one of the major problems with the kicad library. If we update for example the scaling of a 3d model to be 1 instead of 1/2.54 the users get the new footprint with the new scaling factor immediately but they do not get the new 3d models.

This can be avoided by using the local setup. There is a tutorial out there written by @bobc https://github.com/bobc/kicad-doc/wiki/How-to-install-local-Footprint-libraries (notice that everything is done from within kicad. No package manager is involved.)

The parse error came from the fact that we updated the complete connectors_molex.pretty footprint lib. It had one defect footprint in it.

If eeschema crashed for another reason, than this is another bug. I’m only writing about the bug you told us in the first post or more precisely in the title of this topic. (I can only answer to questions that have been stated clearly and for whom i have enough information.)


#10

No, directory /usr/share/kicad/modules isn’t empty. It contains subdirectories with names like *.pretty, which in its turn contains files with names like *.kicad_mod (as I think this is footprint files). 3D models contained in /usr/share/kicad/modules/packages3d with names like *.wrl. All these directories and files were installed from deb-package kicad-library (not downloaded by kicad, kicad hasn’t write access to these locations).

I don’t know a reason eeschema was crashed, but after last update all works fine.
Thanks for help.