Eeschema 5.0.0 --- Edit Symbol Fields


#1

I have a schematic on a single sheet with only a handful of parts. I am attempting to have KiCAD generate a bill of materials in the form my cm likes. Here’s what I have done:

  1. Under Preferences > General Options, I click the Field Name Templates Tab, and add several extra fields to keep everyone happy.

  2. Under Tools > Edit Symbol Fields I get something that looks much like a spreadsheet showing all of my field values.

  3. I fill in everything, and being the first time I’ve done this, change the field values once or twice before I’m happy.

Before I figured out how to add fields globally through General Options, I added some fields manually to each part, but subsequently deleted them. When I edit a specific part’s properties in Eeschema, empty fields are flagged with the option to delete them from the specific part. This does work, as the fields disappear when editing the individual part’s properties.

The trouble comes with the Symbol Fields Editor:

  1. When I open the Symbol Fields Editor, on the left I see several fields repeated two and three times, but is not two different fields; if I edit one, they both change.

  2. Within the Symbol Fields Editor, I cannot delete the abandoned symbol field titles; for instance, I changed ‘mfg’ to ‘Manufacturer’ but the ‘mfg’ field persists.

Can anybody explain how to clean this up so only one column per field entry is displayed, and the fields which are no longer part of any component in the schematic no longer appear?

Any suggestions would be much appreciated.


#2

Can you describe your problem with step by step instructions. I just played a bit with fields, default fields and the symbol fields editor. But nothing unexpected there.

If a field name doesn’t appear in any part any more, then that field name also isn’t listed in the symbol fields editor - just like expected.


#3

Hi Karl,

I created a new design to test this out. I placed the first part in the first library I could find on a sheet. It’s a dual 4:1 mux, 14529.

  1. I placed it, put the mouse pointer over it, and pressed E;
  2. On the pop-up window, I added a field called ‘glitch’ and set its value to ‘field’;
  3. Pull-down menu Tools > Edit Symbol Fields…;
  4. Verified the new field, ‘glitch’ is present;
  5. Pull-down menu Preferences > General Options;
  6. Added a global field, ‘glitch’… same exact name as the local field in the part;
  7. Close the General Options window;
  8. Hold mouse over the one 14529, press E;
  9. There is only one field listed called ‘glitch’; delete it;
  10. Close the Symbol Properties window;
  11. Re-open the symbol properties window by pressing E again;
  12. Verify ‘glitch’ field is still present;
  13. Close the Symbol Properties window;
  14. Pull-down menu Tools > Edit Symbol Fields…;
  15. There are now two fields called glitch;
  16. Turn them both on by clicking the ‘Show’ checkbox next to the part;
  17. Edit one of the ‘glitch’ field entries; change name from ‘field’ to ‘field2’;
  18. Press Tab key, and both fields update to ‘field2’.

How do I remove the duplicate field?


#4

I tried to follow your instructions, without any luck.

What version do you run? I use the rather new v5.0.1: Application: kicad
Version: 5.0.1-33cea8e~68~ubuntu16.04.1, release build
Libraries:
wxWidgets 3.0.2
libcurl/7.59.0 mbedTLS/2.8.0 zlib/1.2.11
Platform: Linux 4.15.0-38-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.58.0
OpenCASCADE Community Edition: 6.8.0
Curl: 7.47.0
Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

Greets, Karl


#5

Hi Karl,

I’m running 5.0.0 on windows 10. It’s a 64-bit build. I just downloaded what was listed as current. I have it on a debian release too: 4.9.110-3+deb9u6, also a 64-bit build. Maybe this got fixed in the 5.0.1 release?

Cheers,
Lawrence