Editing issues in 5.99 - blank text boxes or squished text

Have a minor issue with V5.99 when I am creating schematics.

  1. When I try to search for a symbol, the text box is too narrow and when I type in the search text, it’s cut off on the bottom. The text box is too narrow. See ‘resistors’ in the text box? Too narrow. I’d like to be able to see what I typed. That isn’t the only place it happens either. There are other places in KiCad where I see that.

  1. When I try to edit a symbol on screen, by dbl clicking on the symbol, the editing box opens but if I want to change the device name, when I click on that box, it goes blank, when I try to enter a new p/n, it stays blank. Now, if I want to do a prnt screen of that editing box issue, when I press ALT the text becomes viewable, and it becomes visible if I press JUST Prnt Scrn key. Kinda annoying that I can’t see the text as I enter it. I shouldn’t have to press ALT for the change to appear. See that LM in the text box? That doesn’t appear as I’m typing it. Only appears when I click Prnt Scrn or ALT or other times.

Is this just settings I’ve missed? Or should I wait for 6.00 to be released (supposed to be before the end of Oct but doesn’t appear that’ll happen).

I have not seen this in KiCad, but I have seen it (and been annoyed by it) in FreeCAD.

For me the “Choose Symbol” dialog looks like:

And the Library link at the bottom of the Symbol Properties looks like:

I’m guessing this is not a setting in KiCad, but it is a part of your “Desktop Theme” and it’s interaction with WxWidgets.

Application: KiCad Schematic Editor

Version: 5.99.0-unknown-dd99b2dc2f~142~ubuntu20.04.1, release build

	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-89-generic x86_64, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: Oct 26 2021 22:43:05
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.5.2
	Curl: 7.68.0
	ngspice: 31
	Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:

1 Like

I use 5.99 and have encountered no such issues. So it is not a broad issue with 5.99


Maybe something in Ubuntu but what? And also, why is it ONLY in KiCad? I have 10’s of programs and apps and it only happens in KiCad.

I will try to see if there’s something in Ubuntu desktop Mate app that might be causing it.

It’s probably a GTK (user interface widget library) theme problem, together with wxWidgets UI library which uses GTK on Linux. I think the default Ubuntu theme is officially supported, but trying to support all themes would be an endless swamp. That said, it could be possible to make small changes to the KiCad’s UI code which would fix these problems.

Beyond my pay grade I think. Change the code? I have no idea how that would be done.

That was a generic remark, not a suggestion you should do it. You can file a bug report to the issue database.

1 Like

Okay, have done some more testing. Turns out, I am so used to using Ubuntu Mate all the time that I hadn’t bothered to test out the issue with the other desktops I have on board. The 2 issues do NOT EXIST when using Cinnamon and Ubuntu desktops. So it is only with Mate.

Once I knew that, then I went into Mate’s control center and tried all sorts of different changes with look and font sizes to try to get those two problems fixed to no avail. So what I need do now is to go to the Mate forum and ask my questions there. I think. It’s so strange that I haven’t seen this issue with any other app or software in Mate. Only with KiCad. Strange.

Thanks all!

It’s not strange because most of your applications don’t use wxWidgets UI library.

I’m running Linux Mint now with Xfce as desktop.
I’m not sure when I saw this issue in FreeCAD, but it probably was when I ran either Mate or Cinnamon.

But apparently FreeCAD is (mostly?) based on Qt. So a similar looking bug may have a different underlying cause.

If I knew what a wxWidget was, maybe we could discuss it. HAH!


Hi @Jim_HiTek

I have just reread your previous thread.

You were using an August version of 5.99. There have been very many fixes and very many more recent versions since then.

Have you downloaded current version of 5.99?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.