Edge cuts not visible in 3D

Hey All,
The edge cuts for the PCB seems to be working but not when cutting holes on the PCB

has anyone come across this ?


1 Like

What version.
5.1.x has YELLOW for edge cut
5.99 has GRAY for edge cut

I am on the stable version 5.1.9. And it’s light blue not yellow forms.

Works for me. What layer are you using? Try editing the cut and changing to Edge Cuts.

How wide is that slot, creepage slots should be at least 1mm after tolerances?

Unless the traces on the right are considered fusible, I don’t think the gap will be effective in increasing isolation :wink:

I’m curious what the point of that cutout is, since those diodes are flat on the PCB this wouldn’t increase creepage distance anyway. Also, diodes and especially TVS tend to fail in a short.

Using 5.1.9 I drew a slot just 0.2 mm wide with radiused ends and it displays, although you have to angle the view right to see through the slot.

Is your slot exactly closed?

Nope does not seem to be working for me. I’ve had this several other projects as well.

This seems to be a problem on one of two pcbs in the project. Its works on the left not on the right

Can you share a pcb where this happens, a trivial example one if possible?

And also give your OS, all we know is 5.1.9

Would only the pcbnew file be enough ? OS is Win10Pro_64bit

Application: Pcbnew
Version: (5.1.9-16-g1737927814)-1, release build
wxWidgets 3.0.5
libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.73.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.71.0
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:

Do you get any error dialog when starting 3d view?

Nope nothing at all, which is surprising.
Test.kicad_pcb (1.5 MB)

Actually, it’s the same problem that I met
Footprints with PCB Cutouts

Three holes in the right hand board “weld pedal” and by J7 were not visible.

So I deleted the left hand board and the small board. Now they show.
Is this three PCBs on a panel?

The small pcb stacks up on the right PCB and the Right PCB stacks on top of the Left PCB using the header pins on the left pcb.

Not necessity on a single panel yet to get in touch with a fab house if this would be possible. At the moment yea all on a single panel if possible.

Your are right ! deleting the left pcb works but why not with it ? a bug ?

KiCad has a one project one board concept. Putting multiple edge cut outlines in the same project has triggered some unexpected behaviour, I don’t like to call it a bug as such.

Can someone try the sample deign in 5.99 to see what happens?
You can always raise a bug report anyway. This might be related to some other internal edge cuts issues

Kicad 5.99 same effect.
I’d report this as a potential issue, since we don’t know what’s the relation between multiple PCB and not rendering some featuers. This might just expose some underlaying bug.

How do I report this as a bug ?