Edge Cut graphic over rides copper layer

V606

I had an issue that confounded me for a while.

I couldn’t make connections where shown in green.

  • Bottom copper layer was selected
  • I had the “edge cut” layer invisible
  • Would repeatedly get an error “Cannot start routing from a graphic”

After some time I turned the edge cut layer visible and saw the trace I was attempting to create was right on top of the edge cut line.

After I moved the edge cut line away from the area I was able to add the copper traces.

This is quite normal and expected behavior. You can’t route outside the PCB, or more accurately, you can’t route over the edge of the PCB.

The error message itself could probably be better, but when I read “Cannot start routing from a graphic”, then my first question is “So, what’s that graphic causing the problem?”, and having a look at disabled layers is then one of the first things to do. Sometimes I place most of the footprints and do a part of the routing to get an idea of how big the PCB needs to be before I draw anything on Edge.Cuts, but after I’ve drawn the Edge.Cuts layer, I rarely disable the Edge.Cuts layer, because it gives me a reference about where on a PCB I’m working.

1 Like

Mildly speaking. ,

Pretty sure this is already fixed in 6.0.8 (Rely on DRC rules when items might overlap. (f48ed790) · Commits · KiCad / KiCad Source Code / kicad · GitLab).

1 Like