DXF Export Double Edge Cut Lines- Help

Hello,

I am having an issue when I import DXF files to SolidWorks. While the “edge cuts” layer consists of one line for the board outline, any other layer such as a copper layer has the edge cuts line as two lines which border the outline of the board. Is there a way to have edge cuts on all of the layer with the single line rather than the double contour line?

Thanks!

Could you add a screenshot of the Plot-output dialog (so that we can see the checked/unchecked settings)?

I’ve experimented a bit with PCB Editor / File / Plot and then plot to the DXF format and I think I can confirm this. I see: DXF Options / Plot graphic items using their contours but it does not appear to work as expected. I’m not sure though if this is a bug or deliberate. A part of the reason is that DXF is a very old and quite horrible format. But as a defacto standard for data exchange it’s often “somewhat usable”. Unfortunately this is quite common. Makers of commercial software often deliberately use file formats as a method for vendor lock in.

KiCad’s SVG export seems to be a lot better then it’s DXF export. Maybe exporting as SVG, converting to DXF with some other program (such as Inkscape) and then opening that DXF in solidworse is a viable option for you. You have to experiment in this regard. the generated DXF will be quite different.

My SolidWorks is 22 yrs old so, I won’t bother with it but, I tested DXF’s with FreeCAD.

It looks like things have changed enough in Kicad such that there is now (v6.0.9) a Checkbox to enable getting single DXF lines…

The Traces properly contain lines for trace and the other lines are single (if using the correct setting)


Screen Shot 2022-11-22 at 08.18.28

Yes, I also tried that, but it does not work for me.

Below a screenshot of the settings used in KiCad V6.0.9, and how it looks in FreeCAD.

What happens if un-checking “Plot Edge Cuts on all layers” ? Just curious

@paulvdh - no need to answer my question - I answered myself…(by setting it to 'checked")

These are the same settings I have been using, although I’ve tried many combinations. Unchecking “Plot edge cuts on all layers” gets rid of the board outline and any other edge cuts entirely.

It should ‘get rid of edge cuts’ on all layers. But, notice it also causes double lines. Thus, un-checking stops the double lines (on my system). look at the small line (double line) above circuit. That is what happens even if selecting either of the two DXF options…while leaving it set to all layers.

Saving as SVG and converting to DXF worked well. Thank you!