DRC Reports "Missing connection" on unconnected pads

I’ve encountered a strange behavior when running DRC on a board with unconnected pads…

In this screenshot, EESchema shows that “TAB” is unconnected, in my footprint, I have two pads named “TAB”, and this seems to confuse the DRC.

It says “Missing connection between items” and the item nets are “unconnected”.

Shouldn’t it not report missing connections for unconnected items?

In KiCad, by default all pins with the same pin number have to be connected on the PCB, and a “pin number” is a 4 digit alphanumeric string. “TAB” is just a normal pin number as far as KiCad is concerned. One way to “fix” it is to use other pin numbers for the pads, for example “TAB1” and “TAB2”.

This footprint also does not conform to the KLC According to the KLC additional pads should have consecutive numbers to the real electrical connections, so that would be 7 and 8 in this case. Therefore i assume you made this footprint yoursef, or you got it from somewhere else.

If you edit the pad properties, you can set a Fabrication Property. Maybe you can do something with that, but I do not have much hope. I have not worked with this possibility myself.

1 Like

Hi Paul, thank you for the advice.

The tabs on this connector are purely mechanical, so after fiddling a bit, I’ve found removing the “Pad number” (leaving it blank) solves the “missing connection” problem. It will keep my schematic a bit cleaner as well rather than having two pins I’d seldom (maybe never) use anyway.

I never noticed the “Fabrication Property” dropdown. I tried setting it to “Heatsink pad”, but yes the DRC still complained. Maybe if there were a “Mechanical pad” option that the DRC could look for, but I suppose having a nameless pad is fine enough, and doesn’t seem too hacky.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.