DRC custom rule does not work any more

@JeffYoung This rule does not work any more. Violations are flagged regardless, but should be suppressed (as they were).

#ignore silkscreen overlap violations in rule area(s) 'silk_ok'
#rule area has to be on the respective silkscreen layer(s)
(rule allow_silk_collisions
	(constraint	silk_clearance (min -1mm))
	(condition "A.insideArea('silk_ok')"))

The culprit is

Application: KiCad PCB Editor (64-bit)

Version: (6.99.0-2162-g5e80e2a421), release build

Libraries:
	wxWidgets 3.1.7
	FreeType 2.11.1
	HarfBuzz 4.2.0
	FontConfig 2.14.0
	libcurl/7.83.1-DEV Schannel zlib/1.2.12

Platform: Windows 11 (build 22000), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: Jun 15 2022 07:25:45
	wxWidgets: 3.1.7 (wchar_t,wx containers)
	Boost: 1.79.0
	OCC: 7.6.0
	Curl: 7.83.1-DEV
	ngspice: 37
	Compiler: Visual C++ 1929 without C++ ABI

Build settings:
	KICAD_USE_OCC=ON
	KICAD_SPICE=ON

Really nobody buying into this?

Sorry, I’ve been suffering from overwhelming odds and fearful adversities up til now.

Will try to “spend a penny” now :slightly_smiling_face:

Sorry, too. I didn’t mean to press. Just wanted to avoid the issue to sink into oblivion :wink:
Thanks for your pennies :slight_smile: