DRC Control: Error Clearance Violation

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the KiCad.info forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

Hello yall.

Im pretty new to Kicad and im currently trying to design my own keyboard layout, but i keep getting this error and i dont know how to fix it.

I also changed the default clearance to 0mm but it also doesnt fix the problem.

This error applies to all the vias i set, but i cant figure out why it does that.
If it helps i can also share the project.

Help would be appreciated.

Im using Kicad 6.0.

With 0.0mm clearance the same problem.

Your vias aren’t on a net . . . any idea why not ? do you have a schematic ?

Yes i have, do they need to be on it?
I havent found them in the schematic editor.

Here’s the schematic

The vias on the 5V rail dont have the problem, only the vias that are on the other side of the connection connected to the leds have it.
All switches have a led and every led has the same problem.

KiCad has (at least) two different ways to place via’s.

  1. You can press v during routing of a track to place a via, and these are automatic via’s. (wich always attach to the net they are on).
  2. You can use the via button in the sidebar (or main menu), and these manually placed via’s get a net name once.

If you copy and paste via’s, they probably retain their type. You can also change this by editing the properties of a via.

1 Like

I’m not sure but I think exact via behavior about taking net when placed or moved on other copper things could changed between V6 and V7 (I’m sure changed between V5 and V7). Better upgrade to V7. It would be easier if you and your helpers use the same version.

Any copper (including via) connected together have to be at the same net.

Vias are not placed or defined in the schematic. The schematic shows the logical connections of the conponents. The layout defines the real connections.

I didn’t do a comprehensive reading but didn’t see where this was a ‘foot print’ thing so I moved it up a level. If wrong, someone move it back.

1 Like

Ive removed every via and error invoking component and started to redo the lanes first.
It reduced the warnings and errors.
Ill try the routing with v and look if it doesnt throw any errors

1 Like

If i dont get my errors resolved after reconnecting everything ill try that.

Ive redone the routes and the problem was solved.
Apparently the vias just didnt want to connect properly or i did something wrong.
Thanks for the help!

Do you still have a backup of your project with those faulty via’s? I would be interesting to see whether the Automatically update via nets is set for those vias.

KiCad does have: PCB Editor / Edit / Edit Track & Via Properties, and this dialog has quite a lot of settings for modifying Track & Via Properties, but it can not influence that flag in bulk. This is likely just an oversight, as that checkbox was added after the Edit Track & Via Properties existed for years. I’m guessing it’s worth a feature request to add the ability to set that checkbox in bulk via that dialog.

I sadly didnt think of doing a backup via git, but if i remember correctly the option was not selected.
Im still in the process of lerning to design pcb’s and just yesterday i came across ai03 guide for keyboard pcb’s (or pcb’s in general). Dont know why the idea of doing a backup didnt pop up earlier in my head, as it would have helped right now, but i will be doing them in the future.

It all does not matter very much, but you may want to have a look in the [project]-backups directory. :slight_smile:

Didnt know that that exists (or i just blindly didnt notice it lol).
Here’s the relevant backup.
ky-2023-11-15_230625.rar (763.5 KB)

I did a bit of tinkering with your project, and found two quics ways to repair it. First, by removing the “(free)” keywords for the via’s in a text editor, and the other by first turning off all selection filters in the lower right corner except for vias, then selecting them, editing their properties, and then un-checking and re-checking the Automatically update via nets checkbox and click on the [OK] button.

Could it be related to the “Keyboard footprints placer” plugin?

I am sort of satisfied that there is a quick fix, but I also do not know how your project got into this state. Combined with the old KiCad V6 you made it in, I do not see much benefit in trying to make a bug report or new feature request on gitlab.

I until recently didnt even know that there was a new release for Kicad, i will update to it soon.
I’ll be honest, i dont know either what i did wrong, but the plugin shouldnt have been the problem.
It only alligned the footprint of the switches to the format i wanted them to have, not connect them or anything else.
I did the placement of the other components and the connections between them. Maybe i pressed something or did something that ended up making the vias missbehave or i dont know. But the problem is solved now.

KiCad has a mayor release once a year (KiCad V8 is expected end of February 2024) and it has bug fix releases about once a month (Maybe about 10 per year or so). Bug fix releases can be recognized on increments in the third number. And bug fix release generally has some 70 (or more) bug fixes (That is an average of 2 to 3 bug fixes each day, including weekends). And it’s recommended to update regularly.

There are a few reservations. If you have a company dependent on KiCad, it is probably best to wait a few months after a mayor update, as a mayor update tends to have relatively many small bugs. When you are dependent on KiCad, it is probably also best to wait a few days with updating after a bug fix release because sometimes *&^%$#@! happens and an annoying bug slips through. If that happens, then the release will get pulled and replaced with the next (3rd) number within a few days of it’s release.

For more info, see: