Drag Track with "D" key stopped working in PCBNew

I may be going crazy, but it seems like the “D” hotkey for dragging tracks stopped working on me for the opengl mode of pcbnew. “D” still works in the “default” canvas (F9). The “M” key now seems to do what the “D” key did before. Did I accidentally change some setting? I’m running 4.0.7 on Windows. I still see “D” listed as a hot key:

Try “g”.

more characters…

“g” doesn’t work either in opengl mode, but it does in the default canvas. But a lot of the rest seem to work, like “t”, “o”, “f”, “r”, “e”, “x”, “v”, and the delete key.

Are you sure it ever worked that way in 4.0.x? I tested it in 4.0.6 and it does not work that way. In the v4 releases the drag mode is enabled in the settings of the interactive router and it uses the hotkey “m”. (The setting is called “mouse drag behavior” and you can select between interactive drag and move.)

Only nightly builds (and therefore kicad 5) use the “d” shortcut for dragging.

And worth remembering: drag does not work for traces that violate DRC before you start the drag operation.

Yes. I just now tried it on my home computer with 4.0.7, and “d” works as expected in opengl mode. So it seems like it is only my work machine that has suddenly changed.

1 Like

Ok i played around a bit more. It does indeed work while in the interactive router mode. But it does not work otherwise. (In kicad 5 it works no matter what mode is active.)

You can try to set interactive drag for the mouse drag behavior and use the m shortcut. (this should also work no matter what mode is active.)


Yes, the “m” key works, which would seem to indicate there are no “blocking” issues (like DRC, which reports no errors). Just odd that the “D” key would stop working. And my muscle memory is apparently trained to hit that instead of “M”. Strange.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.