Downloaded a single *.lib + *.dcm file from the KiCad github

So i noticed that my files in my C:\Program Files\KiCad\share\kicad\library are really outdated compared to what i have found at
(i just installed the latest version of KiCad)

After i wasted 5 hours googling how to update my outdated files i decided to manually download “atmel.lib” and “atmel.dcm” from github and put them into my mentioned …\kicad\library folder.
It owerwrote my older, much smaller “atmel.lib” and “atmel.dcm” files.

Then when i loaded KiCad and opened a .sch file i got an error message regarding those two “atmel” files saying stuff like “io error … not an eeschema library”

How should i actually update my stock libs?

Two ways:

  1. Use this link to download ZIP file with symbol libraries from Jenkins automatic build system. (If you encounter Gateway Timeout error, try again)
  2. Go to the KiCad/kicad-library GitHub repository and click on Clone or Download then Downlonad ZIP.

Using both ways extract files from library folder to the KiCad library folder. Backup your current files before copying!


How exactly did you “manually download” them? If you did “Save Page As” in a browser, you might have got some bad data in the file.

I find the simple and reliable way is to download the zip (option 2 in @keruseykaryu post). Note there can be problems copying files into c:\program files due to Windows UAC.


I tried the second option and it worked! Thanks!

I did “save link as”/“save target as” when i downloaded those files. Option 2 worked, thanks!