Download Footprint Libraries

Hello guys,
i am Trainee in a Company and Need to use KiCad cause there is no license for the program everybody else uses for me.
But the Problem is that (atleast i think that is the Problem) the Proxy Server of the Company blocks github.4
So i wanted to download the libraries and download the library-repos-install.bat and Git, but this failed too.
Has anyone of you guys an idea what i do wrong or what else i could do?

can you open github within your web browser?
You than can test if you can download one of the repos as zip from

If this works also test if you can clone the repos via https.
It will be a lot of work to download all libs by hand. Maybe you want to only download the ones you need.
If you want to use this downloaded repos, you will need to remove the preinstalled libs within the footprint library manager. Within PCBnew. Adding libs is done with the footprint library wizard (choose local files.)
If you need help there, simply ask. (I don’t want to go into too much detail now.)

If dis does not work, you will need to talk to your network admins. This would be the best option. (Or the one with the least amount of manual work.)


tried downloading them Manual and this worked :slight_smile: Thanks a lot for the fast help.