Don't fillet zone at board edge

I like using the fillet corners option for zones, but whenever a zone with a fillet reaches the board edge, it ends up like this:

image

I know it’s mostly a stylistic concern, but I wonder if it’s possible some way to get the zone to not fillet certain corners, or to avoid this behavior at the edge cuts layer.

A workaround which may be acceptable to most people: Add a zone of the same net, with fillets turned off, that extends from the filleted zone toward the board edge.

There, I corrected that for you, although it is not entirely true / complete. Apart from only a “stylistic” thing, it is also a waste of time. Note that these corners are also so small that you will barely be able to see them on the finished PCB.

What is important though, is that you enter a value in PCB Editor / File / Board Setup / Design Rules / Constraints / Copper / Copper to edge clearance. In KiCad V7 this value is set to zero by default, and this results in the copper going right to the edge of the PCB. This can cause serious problems in various ways. It can (and will) create burrs during PCB production. Copper is also a soft and a bit gummy material, and it can also get “smeared about” a bit on the side of the PCB. On multi-layer PCB’s this can cause shorts between internal layers, and on a dual sided PCB this can cause shorts if the PCB is mounted in a metal housing.

1 Like

In addition to what @paulvdh has written . . . your board fabricator may also have a min allowable distance between board edge and copper, i.e. you can’t have copper right upto the edge.

The workaround isn’t really a workaround: that’s exactly what same-net zones with different priorities are for: they allow you to control the zone settings differently for different areas of the copper fill.

1 Like