Donation rejected

Having used KiCAD for a few weeks now I decided I quite like it. I tried to make a donation using PayPal and got a message that Donations are not accepted from my country - New Zealand ???

If you could provide more information how did you try to do the donation (URL, etc. etc.) @Seth_h may be able to help you.

First, thank you for supporting the continued development of KiCad! You are awesome!

On the question of how to donate from New Zealand, I will admit that I am stumped. You are the first person who has noted this problem.

You can DM me with details (screenshots) and that would greatly help in diagnosing the issue. Unfortunately, with PayPal, we receive only minimal information but I can always ask them for more details.

Not sure if that helps much, but shortly after @kavala asked the question here I saw a similar question on another forum about a different open source project. It was also a person from New Zealand paying via PayPal.

I tried again. Same deal…

Thanks. I’ve reached out to PayPal. Quick searches on the internet say that one way around is to send the donation to the e-mail address instead. In our case, that is donations@kicad.org

Sorry for the inconvenience and thank you for your support

Not sure how to do that ???

Ah, I figured it out. Donation now sent via Paypal…cheers.

5 Likes

On a related issue, if you donate, can you get a receipt? I do keep thinking my company should donate to kicad as I use it as my primary tool for CAD these days. For accounting purposes though I would need a receipt/invoice.

Yes, absolutely. You do receive a receipt from the payment processor but if you need additional details (company name/address) just send an email to donations@kicad.org and list the information that you require.

1 Like

Well I went to download latest version and had the same problem. I could not use PayPal to make a donation. So then I used the method below and made a donation using PayPal, using KiCad email address. This donation was successful, but I am unable to download the new version because when I attempt to download, I can’t get past the ‘Donation’ process ???

Ah, I see it was downloading the new version, but did not notify me of that.
So problem solved. New version installed. Donation made.

4 Likes