Does this footprint work for you?

Is that an undocumented feature? I don’t recall ever hearing that advice before this. Once it’s in the footprint editor, I assume you can save it as a new footprint(s) and it will be automagically saved in the current format (compatible with the “.pretty” footprint libraries).

Several years ago I recall converting some old-format libraries to the *.pretty format, using the procedure described by @keruseykaryu in the thread Question about .mod and .pretty files.


1 Like

I just tested your library.

open the footprint editor.
open the library manager (found in the preferences menu)
press the browse button on the bottom
browse to the location of this file and select it.
(If you can not see the file then switch kicad to english as a workaround for the language bug)
press ok.

Now you have the footprint library active in kicad.
You can then open it like any normal footprint and copy it to whatever lib you fancy.
After that you can delete the lib again.

I have a video showing you what to do. I created that one for the discussion where we discovered a bug with the language settings. So the filename is of course a bit different.


No. Just that the import dialog was missing the *.* option. So .mod extensions won’t show up in the file browser. You could as well change the extension to .kicad_mod as the format is detected by content not extension.


Tested with KiCad v5.0.2 and seems to work. Perhaps you could post the error you are seeing.

Here was my procedure:

I don’t see an error message, but when I change the footprint file name from .mod to .emp and then go to add the footprint to a library I cannot select it in KiCAD. Basically no matter what I do, whether the file ends with .kicad_mod or .mod or .emp, it is always grayed out and will not let me select it when I go to select it to add in my footprint library editor.

Rene_Poschi, thank you for the video!

Still working through some missing component errors on my PCB but it seems most things are working as they should

The footprint not found in any library is because you switched version mid project.

The pad not found message however is a lot more dangerous. It basically tells you that you connected a footprint to the symbol in question which is not compatible with it.
KiCad knows which footprint pad is connected to which symbol pin via the pin/pad numbers. More details see: How does KiCad know which symbol pin represents which pad of the footprint?

1 Like

Here is a picture of what I see when I try to import and the .emp file is grayed out:

Thank you for pointing that out. I found a git someone put up that had the Arduino Teensy 3.2 and footprints so looks like I need to find a better one that matches for both the symbol and footprint!

Did you ever try the route i suggested above? The one where you simply add that file to the footprint library table?

1 Like

Hmm… Let’s see if we can summon a Mac expert (@JeffYoung) and see if he knows why the choice is grey. Offhand I’d guess that it’s looking at the file association but that seems odd to me.

1 Like

It would probably take a comparable expenditure of your time and effort to modify the symbol and footprint you already have, so that they are compatible with each other and fit your requirements. You will almost certainly need to do this eventually, and you should know how to do this if you expect to do more than one or two boards a year. From a philosophical perspective, knowing how to make your own symbols and footprints (or at least edit and modify other people’s symbols and footprints) is comparable to a fisherman knowing how to bait his own hook.


1 Like

Yes I still got missing footprint messages until I also added a new path to each of my libraries. I would just make these footprints again but the footprint wizard isn’t working for my in V5:

I found a design online because adding and creating the location for each pad took forever to make a footprint. Then I found the footprint wizard and making footprints got so much easier! THen I upgraded to V5 and my foorprint wizard doesn’t work so back to the start lol.

When I upgraded to KiCAD V5 I deleted the libraries because I think I misunderstood the directions (my libs were stored locally not using Git), so then added back my custom libraries back in. I think the local KiCAD libraries are stored in a different location locally so I’ll have to try to find them and add them back in.

You could check out this tutorial. It shows a lot of tips and tricks of how to work efficiently with kicads footprint editor: Tutorial: How to make a footprint in KiCad 5.1.x (From scratch)?

For scripting footprints there is also the stand alone scripting stuff that is used to generate a large part of the official library. This can be found here:

1 Like

Thanks for the info, it is much appreciated I will check it out! I had used the Footprint editor in V4.07, that was lovely, then I went to use it in V5.01 and started getting errors.

I assume you mean “footprint wizard” not “footprint editor”?
If you get errors in the editor then this would be new information.

1 Like

Yes, you are correct…I meant footprint wizard. Every time I try to select a footprint type I get an error and cannot make any footprints:

@remote1, do you have “Show all filename extensions” checked in your Finder Preferences (in the Advanced tab)?

Most browsers will append .txt to text downloads. If you don’t have show all extensions on it might be truncating “0436500200.mod.txt” to “0436500200.mod” (and similarly “0436500200.emp.txt” to “0436500200.emp”.

An easy test for this is to double-click the file in Finder. Does it launch TextEdit, or does it say something like “Application to open this file not found?”


Thanks Jeff for the suggestions. I did not have the “Show all filename extensions” checked, but I do now. When I try to open a .mod file or a .emp file it tries to open with VLC. I set video files to open by default with VLC but not sure why it wants use VLC for this.

Still no luck importing. Since changing the filename extensions it now sees the .emp file as emp.mod and .mod files as .mod (see pic)

There is something slightly odd about this but I have got this to work in macOS.

In the footprint editor, click on the ‘import footprint’ button.


In the dialogue, navigate to your footprint. Ctrl click on the filename of your footprint and rename with the suffix. ‘.emp’ and click on open.



If @John_Pateman 's suggestion doesn’t work, try renaming the *.emp.mod file to just *.emp.