Does Kicad work well with intel X4500 old integrated graphics


#1

I tried several windows like win7,win10,vista,xp,etc,on my old notebook computer with intel x4500 graphics card.Pcbnew can’t work in Modern tools(F11)。But to my pleasant surprise,it does work well in Ubuntun Kylin18.04 in the mode of modern tool(F11).I just want to know is there some method to let Kicad work well in windows for my old laptop(modified graphic drivers?)?If not,I will not waste time to search for the way,and will use Kicad in Linux.Thank you!


#2

For Windows, I’d check the Intel Driver Download Center if they have updated drivers for you — quite often the drivers shipped with mainboards are a bit behind.

On Ubuntu, drivers are updated automatically with the rest of the system, so chances are you are more up-to-date there.


#3

The Intel GMA 4500 only supports OpenGL 2.1
The last Windows driver is from 2009


#4

I download a modified graphics driver called “Win10Vista_151719”(The driver revision is 8.15.10.2869) which support OPENGL2.1.With the modified driver installed,my notebook can run CS1.6 in OPENGL mode,and also can play a Minecraft alike game which needs OPENGL.But I tried F11 in Kicad pcbnew,it popped out Microsoft Visual C++ Runtime error.I tested in win8 this morning.Some days before I tested in Win10 in another laptop with intel GMA4500 graphics with the same modified driver,it popped out a warning “Requested render buffer size is not supported”,and still remained in fall back mode.


#5

The intel gpu druver has a bug in its opengl handling of buffers. The nightly have been patched against this to my knowledge (simply not using those routines when an intel gpu is the main display driver)