Does Fab File Output Work in 4.0.7?


#1

Not sure whether this is a general layout question or just gerbers. Anyway, I have a small board. When I try to print the fab files, I cannot use scale magnification in all output settings except HPGL and postscript. Why doesn’t KiCAD 4.0.7 allow me to use scale magnification the the fab file? Also the postscript output, besides being jagged (expected), does not respect invisible fields and prints them anyway.

It seems to me that 4.0.7 has a serious problem with fab files. I am using 4.0.7 on Ubuntu 16.04.3LTS.


#2

Both the native KiCad board file and gerbers are meant for physical board manufacturing. It’s not a board editor software’s responsibility to scale the gerbers. Gerbers aren’t meant to be scaled, they are 1:1 representation of the board. (Although that’s theoretical, the measurements are only numbers.)

But if you want to print out the gerbers you can print from the gerber viewer instead of the board editor. Gerbers don’t have invisible fields, and you can scale the printout.


#3

Thank you.

Yes, I can understand why the gerbers cannot/should not be scaled. They are used to actually etch the pcb, so they should be accurate to 1:1 scale. But how about the fab files? The fab files are different than the gerbers, although they can be output in gerber format. The fab files are used to assist e.g. with manual work on the board. They don’t have to be at 1:1 scale, but any scale that makes for a comfortable display of the board (magnification in my case) can be used. Plus, if fab files are not meant to be output at 1:1 scale, why do the HPGL and postsctript formats allow for magnification, but the other formats don’t?


#4

What you actually want to achieve? Do you want to print something to paper, and if so, what?


#5

Yes, I want to print the fab files on paper, so that, say, a technician can know which component is where. In principle, this can be done by changing the size of the refdeses on the silkscreen (currently zero for most of them because there is no space for refdeses) and printing each side of the board. But this is more tedious. Each footprint may look different in the fab layer than on the top or bottom layer of the pcb.


#6

So use File->Print, which allows scale to be adjusted.


#7

Thank you, bobc.

I followed your recommendation. I found out that if I print to my PDF (virtual) printer, KiCAD screws up some arcs on the edge cut: it insists on printing the whole circle! However, the preview looks fine. I am not sure if there is something wrong with the PDF virtual printer.

So, I selected print, then selected output to file, and there I had the choice to output in pdf. The output came out as expected. (So, I guess printing to the PDF virtual printer has some quirks, but printing to a file doesn’t…) NB. My selection to print one separate file per side is ignored and all comes out in one file. Also, you may want to have both fab layers (top and bottom) turned on from the visibility bar; otherwise you may get a blank output for that side.

The bonus of selecting to print (vs. plotting) is that it gives the option to scale to fit to the page.

Thanks again for the suggestion!


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.