DNP symbols are written out to pos files

the new DNP feature doesn’t work for me as described in the release notes. If I set the DNP flag of a symbol, it is greyed out, has the red cross on it, and it has a ‘DNP’ column in the BOM. But it is still written out to position (.pos) files. Because of this the “Toggle 3D models not in pos file (P)” switch of the 3D viewer doesn’t work either.
I am using KiCad 7.0.0 on Win10.
Has anyone else experienced this?
Any hints are appreciated.

DNP items should be written out to the pos file, because it’s helpful to still have the location indicated where they would be populated. There is a separate flag to exclude footprints from position files if desired.

Yes, I have found that option in PCB Editor, but it is double work, and the behavior written in the release notes is different:
’ Do No Populate Support

Support has been added for explicitly marking symbols in a schematic as Do Not Populate (“DNP”). The resulting symbols are grayed out in the schematic and marked with a red cross. DNP symbols are excluded from any KiCad-generated placement files.’

I think there should be at least one config setting that connects the both flags.


Yes, the release note is incorrect.

You can raise an issue for this for discussion on GitLab. There are use cases where we need all components (including DNP components) to be in the position file, so any link would have to be optional.

1 Like

I created an issue for this:

1 Like

I found quite a useable workflow to mark every “Do not populate”-component with “Exclude from placing files” in its Footprint:

  1. Open Schematic Editor and PCB Editor simultaneously
  2. Select every DNP component in Schema Editor → Components will be selected in PCB Editor too
  3. Tick the option “Exclude from position files” in the left-hand sidebar of footprints properties for all selected components at the same time.

Thank you, Sven!
It is a quite good and usable workaround!
If you want to exclude DNP parts from the exported step as well, you have to select the option below (‘Exclude from bill of materials’) too. At this point I am wondering why we have two places to export BOMs from? I usually export BOMs from the schematics editor since it has more options.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.