DNP and the 3D viewer

I am completing a board and want to screenshot a couple of 3d renders. I have various parts marked as DNP in the schematic and they are crossed-out properly.

However, the DNP parts still show up in 3d viewer. I thought I read something about another selection that controls this visibility but cannot seem to find it. How do I turn off 3d renders of DNP components? thx

You can turn off visibility in the footprint’s properties, under the 3D settings tab.

Hmm, so I need to get a pencil and paper and make a list of all the DNP parts marked in the schematic, and then edit footprint properties of each of them, one at a time, in the pcb editor, and then use 3d viewer.

That will get the job done, but I was hoping for a checkbox somewhere: “enable/disable 3d renders of DNP parts” or something like that.

Candidate for feature request?

1 Like

This issue recently added on the development branch may be of your interest:

This is also related:


One other nicety would be that DNP parts get a cross-out on the Fab layer.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.