Display inverted

Hello,

I haven’t used kicad since 5.0.2, and while starting a new project i downloaded latest stable (5.1.5).

I’m facing a strange issue : the display is mirrored… (not the texts and menus, but everything that is rendered in the schematic and library…)

When running 5.0.2 I do not have this issue.

Running in a Windows 10 (x64, 1909) in a VM.

Any idea ?

thanks,
Manu.

That is strange, I have never seen that before. Try to switch rendering canvas, Accelerated (opengl) vs Fallback (cairo).

Also try to play around with the guest additions in that VM :open_mouth:

1 Like

ok, definitely something to do with accelerated rendering,setting anti-aliasing to 2X solved the issue !

probably VM graphic driver issue.

thanks for the hint !

Out of curiosity, why do you run KiCad in a VM?

I installed all my tools (kicad, pic ide, etc…) in a VM so I can easily move everything from my home (desktop) to my work (laptop) computer when needed by just copying the entire VM.

At least I’m sure to have the same version, same libs, etc…

not the most efficient way maybe, but it works.

1 Like

I’ve seen this same problem recently on this forum.
Apparently it had something to do with locale settings. (which are possibly triggered by a bug? But that’s premature speculation).