Disaster with Ubuntu 18.04


#1

After upgrading to Ubuntu 18.04 Pcbnew does not start.
Schematic ok.
Tried installing from command line, software center, and software center-snap.


#2

Several reports that both 4.0.7 and 5rc… are not working on 18.04
Python bindings and Gtk3 are suspects


#3

Please add your information to this bug report (https://bugs.launchpad.net/ubuntu/+source/gtk2-engines/+bug/1769215). This will help get this resolved.


#4

What information should we add?
Kicad version and Ubuntu Version?

would it be possible to downgrade python-wxgtk or something as a workaround?


#5

I had the same / similar bug with KiCad V4.0.7 with Debian Testing / Buster.
EEschem runs, But PCBnew does not.
Read on this forum that somone with Arch had a workaround by downgrading wxpython.

Luckily I have a dual boot system, and have the same /home with Linux Mint 17.3.
This is a pretty old Linux distro and PCBnew runs fine with it.

I also had problems with FreeCAD 0.17 with Debian Testing/Buster.
The package manager version could not start, but the “appimage” blob did.


#6

out of curiosity, would compiling/packaging 4.0.7 with scripting disabled make it run again? (just from what I read on the launchpad bugs)


#7

Yes. That would be good. Also be sure to mark the “This bug affects me” button.

If Canonical decides to re-include a gtk2 version of wxpython, this issue will go away. Keep in mind that the chances of this are probably low but definitely 0 if they don’t know that the current choice negatively impacts their users.


#8

Well that ubuntu joins the distros with this problem should now really be a wakup call. Kicad really needs to move on to whatever follows wxpyhton-gtk2. (Will be interesting if even the slow debian will ship wxpython against gtk2 till end of life of kicad 5)


#9

I also had the same problem. Since I could not afford to wait I ended up installing the nightly release of kicad which seems to work. Of course this is not stable version. But it works for me.

Here are some launchpad bug reports:
https://bugs.launchpad.net/kicad/+bug/1768174

https://bugs.launchpad.net/kicad/+bug/1769515


#10

The Ubuntu forum thread has been derailed by bad information and the maintainers have got the idea that 4.0.7 is ok and that it is a custom compile that fails.
Please try to be accurate with bug reports and don’t muddle up between 4.0.7 and Nightlies.


#11

A fix is now available in the repository. Removing and reinstalling kicad-4 fixed the issue for me.


#12

Thanks for that. My own 18.04 is a fresh install and I have already gone to v5rc as I want to test v5 as much as possible


#13

After reinstalling Kicad everything ok


#14

Did you remove and re-install from the software manager or terminal? I tried this a few times from the software manager and had no luck (UbunstuStudio 18.04, Kicad 4.0.7)


#15

PCBnew kept crashing, same as others above reported. I removed scripts from ~/.kicad_plugins directory and resolved the crash issue.

Fresh, clean Ubuntu 18.04 install.

KiCAD Info:
Application: kicad
Version: 5.0.0-rc2-unknown-da66005~65~ubuntu18.04.1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.58.0 OpenSSL/1.1.0g zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-22-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.65.1
OpenCASCADE Community Edition: 6.9.1
Curl: 7.58.0
Compiler: GCC 7.3.0 with C++ ABI 1011

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON


#16

from terminal.
Should be:
sudo apt remove kicad
sudo apt update
sudo apt upgrada
sudo apt install kicad


#17

You should have js-reynaud/kicad-4 repository enabled


#18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.