Disaster in Net List migrating from 6.x to 7.x

This is a project I created and finished with 6.0.x version
It is working fine.
However, I opened it into 7.0.1, I just pushed the button Update form Schematics, and it scr*d up all the netlist.

it’s NOT my intention to redo the routing, of course.
Why dos the 7.0.1 behaving in this way?

Never occurred with any update before this.

without looking into the (old, unconverted v6) project itself it’s only a guess.
Kicad v7 has changed the autogenerated netnames (for nets which don’t have a label or powersymbol assigned).
So this autogeneration-algorithm creates different netnames in v6 <–> v7 and so there is a discrepancy between board <–> schematic.

This will not really help you., it’s only a (possible) explanation.

ok but this is scr*ng up all the projects. Is there a way to remove this stuff form the old projects? it’s urges to be strongly avoided in old projects … it’s not a grill.

All old projects are NOT MORE editable! This means somebody condemned us to redo everything.

This IS unreliability.

Works For Me. Never happened to any of the projects I migrated to v7, but then I always sort out any ERC, symbol and footprint issues before I move on to the layout.

I didn’t modified anything and moreover: everything was super-fine in 6.0.x (the very last version … I don’t recall the last number ) … the PCB was even manufactured and delivered. No errors.

now, I just (and even erroneously) clicked on that button, and the disaster occurred.
it’s blatant, it’s evident … It’s not my intention to remake from scratch any routing of old project for small updates . This behaviour i threatening all the old projects. Indeed I tried now with another, and I got the same result.

Make sure you did not changed the Pad numbering or symbol Pin numbering during some library update. To me it seems that some of the components are just reversed and should be just connected to GND plane with the other pad.

You are saying nothing in the physical layout (pads, tracks, zones) changed, i.e. nothing was moved or resized or something like that, but KiCad insists on connecting items which weren’t previously connected?

To me the screenshot doesn’t look like that. For example, here D6 seems to be in a wrong place.


Or do you mean that KiCad moved some components?

It’s very difficult to say anything definitive without having the actual project in it’s original v6 form and trying to convert it to v7.

1 Like

Exactly: I didn’t change anything. 0 … null … I opened it because I wanted to edit some serigraphy (silklayer) but I just clicked on the update from schematics instead of to open the schematic… and apart returning not-existent errors, it start to consider not connected what is not only connected buat also manufactured.

I didn’t change anything on schematics/PCB of that project. Zero. I had not any reason to do it. (check just my comment above).

But if you have changed a symbol/footprint in your libraries and then updated your schematic, such problem might happen. The main reason being the libraries no longer being in sync with the project.

D4 also seem wrong. Looking at the zones shape, these parts have been SMD before.

You are right, and D5, too. As if small SMD diodes were replaced by larger THT diodes like D2.

Which again could theoretically come from library discrepancy…

my guess based on similar effects: all the diodes have been somehow changed into a different footprint (THT instead of SMD) and their pads have reconnected existing tracks in their new positions to their respective nets, leaving the original and intended connection open.
The simplest way to fix this should be assigning the correct footprint to the diodes and updating the board. If this doesn’t work, moving the diodes to an empty area should at least reassign the tracks to their original nets.

The automatic reassignment of tracks to different nets can cause all sorts of weird and confusing behaviour, especially if multiple tracks get connected to the same net or a large net like GND is affected.

All parts were SMD sicen ever except a rectifier in the power supply input (not into the picture).

The point is: this occurred since I got the 7.0.1 (I didn’t open this with 7.0.0)
I didn’t change anything on library, schematics etc. I just opened the project. This must not occur to anyone.

It seems you are angry and / or frustrated, and you’re venting a lot, but I see very little info on what actually went wrong (according to you) during the transition of V6 to V7.

Are we supposed to deduce your problem from a low resolution screenshot and without being able to compare it with the original design? You have probably been looking at the layout of this PCB for many hours during it’s design, but for us there is no such knowledge.

1 Like

yes I’m quite angry in this moment. I can’t admit things are suddenly change in this way into a project that was fully finished.
Just by reopening it and do not know not only what’s occurred (since I’m the only one that can touch it and have access to it) and do not know on how to put the things as they were.

Not only that: all the old project have the same issue. And I’m getting lost.

OK. The first little step towards finding the root of the problem would probably be to show the footprint field of the symbol which now has the wrong footprint. Then follow it in the fp-lib-table, i.e. Manage Footprint Libraries dialog where the library name is the Nickname.

Because you can reproduce it,
you could open a github issue, describing the way to reproduce it, and share a project in private to a kicad developer…

I didn’t installed 7.0.0.
When I installed 7.0.1 I spend some time opening each of my V6 projects and saving it as V7.
I didn’t noticed any problem, but I didn’t modified anything.
One of those projects I copied to new name and made a next its version so I have several times used Update PCB to schematic function and I also didn’t noticed any problem.
During these I was also doing some changes in one footprint but when I update footprint at my PCBs I always select to update all footprints (to ensure that everything is up to date) and I also didn’t noticed any problems as well.
So I don’t have the sources to show developers where is a bug, but you have. If you can’t send your files than may be you can reduce your V6 project (using V6) to something being not confidential and make a bug report with it just to help KiCad being free of bugs.