Disable auto snap to pad when moving footprints?

I just find it very awkward that when you hover over a footprint and press M, your cursor snaps to the first pad of that footprint. It gets frusturating when you just want to make a tiny movement while zoomed and that pad is off-screen, because it teleports the whole footprint to the center of the screen.

Is there a way to disable this feature?

Pcbnew / Preferences / Preferences / Pcbnew / Magnetic Points / Snap to pads

[Edit] Oops wrong function indeed. The link above adjust whether you want to use a pad as anreference point to snap other things to. Not which location is used as a reference for moving a Footprint itself.
[ /Edit]

But I’m not sure if you want to turn it off.
When you grab a Footprint by a pad, then the center of the pad is used as an anchor point, however, if you start with Silkscreen or something on the Fab layer, then the center of the Footprint is used.

Addition:
A thing that I do find annoying is that the old location of a Footprint is used as an additional snap point, which makes it difficult to move a Footprint a little bit. It’s also not needed. If you want to back off from a move you can simply undo it.

Mine is set to “When creating tracks” though, not “Always”. I assume this is different then.

It’s kinda weird how it teleports your footprint if you are zoomed it. I think it could snap to a closest pad in the zoomed in area instead, but that’s just me.

EDIT: Just tried setting Snap to Pads from “When creating tracks” to “Never”. Still the same, snaps to pad when moving footprint. So ya, that’s something else.

Euhm,

Just remembered that for for most THT Footprints the “active location” is the center of Pad 1. You can however also grab it by any other pad. Just hover over Pad 8 for example and the press M

1 Like

Oh, that’s somewhat better. Thanks.

If you’ve selected a Footprint, there are also other options to move and position it.
With [Right Mouse Button] you can for example select Move Exactly or Position Relative To from the context menu.

@Elmazz Which version of KiCAD are you using ? on 5.1.6 the cursor snaps to the pad, but the footprint doesn’t move (I do remember however the effect that you show, hence the question).

Further, before moving the fooprint press ALT, this disables snapping until you let go.

When starting a move with silkscreen or something it isn’t specifically the “center” of the footprint, rather it is the defined “centroid” of the footprint (by default 0,0 in the footprint editor). In SMT parts, this centroid is where the vacuum pickup tool of the PNP machine holds onto the component. Usually this is the center of the component, but may be off center for some oddly shaped/balanced SMT devices. Usually for THT devices (I think according to KLC, but I haven’t double checked) this centroid is centered on pin 1. That is (probably) why in the OP’s animation trying to move the part, it snapped to pin 1.

If he, instead, selected the footprint and then tried to move it by grabbing one of the pins that was in view it shouldn’t snap to pin 1.

I sorta know al that, but sometimes my thoughts are translated a bit chaotically when they go through my fingers…

I just happen to have a connector on a PCB which is from an old KiCad project and does not conform to KLC. When grabbing this footprint by a graphical feature it uses a corner as the anchor point, as you can see from the dark blue marker in the Footprint Editor. With the button at the mouse cursor you can change this reference anchor.

I made (or modified) this footprint years ago. I can’t remember if it was a modification from an existing footprint, or if I made it from scratch myself. I do know I did it in a nightly of KiCad V4, and when that got too unstable to work with, that project got stranded for a few years…