Dimensioning a component

I want to alter a Transformer footprint to match the one I am using. I have been able to alter the mounting holes and the on-drawing name and save it in my project library. I now want to alter some of its dimensions, overall and pin positions, what is the best way to do it?

I do not understand.

First you write:

And then you ask how to modify it?
But you just did that???

once a footprint has been copied to a personal library (The default libraries are read-only) it can be loaded from the Footprint editor, modified at will and saved again.

If any of these steps causes you trouble, then please explain where you get stuck.

Thanks paulvdh.

I can’t see how to make dimensional changes in the Footprint Editor. I have only been able to alter text related details.

First click on an item to select it.
Then drag it with the mouse.
When things like a line or a pad is selected, small white squares appear, You can drag any of the squares to change the dimension of the property that the square belongs to.
If you have trouble selecting a line, because it is for example not exactly on the grid, then drag a small box from right to left over a section of the line. This usess a “crossing box” to select an item. Dragging from left to right, only items fully enclosed by the box get selected.

Click on an item to select it.
press e to edit it’s properties and enter coordinates.
Usually properties of an item can only be changed when a single item is selected. It does not work on a selection of items.

Thanks Paul.
So positions and lengths are all controlled by their coordinates. A little puzzling is that several of the ‘items’ I select seem to be made of one of two or three parts, for example the outer lines of the transformer I chose (Printtrafo CHK EI30 2VA 2x Sec) Is that is to represent its thickness?
Can they be changed together?

Hi dabbler,

Where can I find the footprint (Printtrafo CHK EI30 2VA 2x Sec) you wish to modify.
I am having trouble understanding your request for help.

It is in the standard component list.

I suppose that you are speaking about lines at different layers.
CrtYd is the place needed for element (with some margin)
Fab is real dimension of element
Silk is what you need to be printed on your PCB.

Hi @dabbler,

No. Each layer must be changed individually. See @Piotr for a description of the different layers.

To edit your transformer, use the grid settings on the top bar for a reference.
eg. by changing the grid to 50mil (.05inches) there are 4 grid spaces between pads 1 & 2, so, pins 1 & 2 are 200 mil or .2 inches apart.
If your transformer pins are 500 mil (.5 inches apart), you will need to have 10 grid spaces between pins 1 & 2 if you set your grid to 50 mil.
Setting your grid and using the four arrows on your keyboard is how you measure all the parts of your footprint.
100mil = 2.54mm = .1 inches.

Delete, edit and add pads as necessary.
Don’t be afraid to change the grid to make life easier to locate pads and layer outlines.

There’s a much easier way of measuring distances than counting grid squares. There are two coordinate displays on the bottom right of the editor window. The first is the absolute cursor position and the second (dx, dy, dist) is the position relative to your reference. You can set your reference at any time using the space key. This, combined with hotspot snapping (and of course the correct grid) is a very useful function that can save you a lot of work.

Thanks all.
I am familiar with layers in my Engineering Cad program, but not in KiCad!
I presume they can turned off as required?
The terms you have used, ‘element’ , CrtYd, Fab, Silk, are all new to me. I will go and read the Manual !

OK I have a starting understanding of the layers and have a footprint that I think matches my trafo.
Any comments welcome.
Transformer_Block_2_1.5_`5.kicad_mod (1.9 KB)

If you haven’t found it yet, here is a FAQ item that describes what all the layers in PCBNew and the footprint editor are for:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.