Did 7.0.9 break 3dConnexion Space Mouse compatibility?

I was really happy that v7.0.2 worked great with the 3dConnexions SpaceMouse. But after upgrading to 7.0.9 this was not any longer the case.
Any ideas?
I already have tried downgrading - but no luck yet…

What operating system?

Please be careful with the version numbers.

sorry - macOS sonoma

Having the same issue; 7.08 here at work, 7.09 at home. Home is i9, work is M1Max. I think the break happened a few versions earlier than 7.09.

Application: KiCad Schematic Editor arm64 on arm64

Version: 7.0.8, release build

wxWidgets 3.2.2
FreeType 2.13.0
HarfBuzz 7.3.0
FontConfig 2.14.2
libcurl/8.1.2 (SecureTransport) LibreSSL/3.3.6 zlib/1.2.12 nghttp2/1.55.1

Platform: macOS Version 14.0 (Build 23A344), 64 bit, Little endian, wxMac

Build Info:
Date: Sep 29 2023 12:23:42
wxWidgets: 3.2.2 (wchar_t,wx containers)
Boost: 1.82.0
OCC: 7.7.0
Curl: 7.77.0
ngspice: 38
Compiler: Clang 13.0.0 with C++ ABI 1002

Build settings:

ok - had really to go back to 7.0.2 - works at least…

and 7.0.5 breaks it…

You need to enable it in advanced config, see the comments of this issue for instructions. It’s disabled by default because the drivers cause crashes for some mac users.

Created a file named kicad_advanced, per the linked issue. Contents of the file is a single line


Restarted KiCad. Still no spacemouse.

Have I gotten the linked instructions wrong?

Same thing on home machine. Intel i9, Sonoma, KiCad 7.09. Created file as above, placed in folder with json color themes. No space mouse here either.

In both cases the space mouse is operational outside of KiCad.

The instructions:

go to Kicad > Preferences > PCB Editor > Colors and click “Reveal Themes in Finder”.

That will show the “Colors” folder, and next to it will be eeschema.json, kicad.json, etc. There should also be kicad_advanced, which you want to edit with Text Edit and add the line:


Is the file next to the mentioned .json files and not in the Colors folder?

EDIT: you can also test if the file works at all. Turn on some other option there from which you can get feedback; see common/advanced_config.cpp · master · KiCad / KiCad Source Code / kicad · GitLab (or rather common/advanced_config.cpp · 7.0.9 · KiCad / KiCad Source Code / kicad · GitLab for 7.0.9). For example ExtraZoneDisplayModes shows an extra icon in pcbnew:


does not work as well…

Do you mean that another advanced flag doesn’t work, either? If yes, there’s some problem in reading or loading the kicad_advanced file. Another thing which comes to mind is the file name: it’s easy to accidentally use - instead of _.

no - name is “…\kicad\7.0\kicad_advanced” but obviously it is not read / found…

I am suspicious of TextEdit in this case. Underscores vs. dashes or ems, ‘smart’ quotes, I thought of typography as a potential cause of the ‘failure to load configs’ problem as well. Thanks to @eelik’s pointer to the relevant section of source code, I verified my spelling of the required filename and of the option to set in that file. I then found myself with two files in that folder named kicad_advanced, because apparently MacOS is hiding my extensions again. Wiping both, creating a new file, no extension, correct name and correct option spellings, and I now have my 3D space mouse working again. Joy! and relief! I expect similar success at work tomorrow.

Thanks all, your guidance and patience are greatly appreciated. Fingers crossed no crashes yet.

yes - you are 100% right. TextEdit and macOS are misleading. Had as well an invisible ending/extension on the config filename which I had to remove manually - now all works as expected!

Thanks for this.
TextEdit also saved my file with an extra hidden .txt extension.

Hello Space Mouse users, could you please check if your mouse with the latest driver works in the just released 8.0.0 rc1? Downloads | KiCad EDA
This installs beside other KiCad 7.x installations.

See latest comments:

Should be good to confirm this. My tries with the kicad_advanced file didn’t work (on Win10).

I installed 8.0.0-rc1, release build yesterday; 7.99 a week or so ago. I did not repeat the exercise with kicad_advanced. My SpaceMouse is already working, gloriously, in 8.0 as well as 7.99. I am on an M1 Mac.

Thanks @rco3. Good to know and nice to hear. I assume this defaults now to enabled. Because there is this version check in background.
Hm, someone on Win(10) who can confirm that the Space Mouse works? Perhaps I should start a new thread?