Designator text ignores "Board Setup..." defaults on "Update PCB from Schematic"

When I do “Update PCB from Schematic”, the imported footprints have a designator text size that is specified by the footprint rather than obeying my “Board Setup…” defaults. I then have to go to “Edit Text & Graphics Properties” to force the designator text to my board defaults.

Is there an option to set that gives the “Board Setup…” defaults priority over the footprint defaults?

Thanks.

With that you probably mean these settings:

Those settings are only for newly created items, such as manually adding texts to the PCB.
Footprints that come from external libraries have pre-existing text sizes set in their own properties.

So it seems very unlikely to me tere would be a setting for this, but the “Edit Text and Graphics Properties” dialog is quite powerful and quick to use.

What you can do is create and manage your own footprint libraries and then set the text sizes to what you want.

It’s probably not very difficult to write a script and set all the text sizes in all library footprints to some pre-defined sizes, but you have to get past your OS’s read-only attribute, and re-run the script after each update of the libraries from KiCad itself, so it’s a quite dirty hack.

1 Like