Dependency problems prevent configuration of kicad-dbg V5 in linux LMDE

I have downloaded the KiCad V5 from here in my Linux OS (LMDE 3 “Cindy” - Cinnamon (64-bit)) like this :

$  uname -v
#1 SMP Debian 4.9.168-1+deb9u4 (2019-07-19)

but when I want to install it by this command:

sudo dpkg -i kicad.deb

i get this error:

sudo dpkg -i kicad.deb
(Reading database ... 504372 files and directories currently installed.)
Preparing to unpack kicad.deb ...
Unpacking kicad-dbg (5.1.4-201908052210+e60b266~84~ubuntu19.10.1) over (5.1.4-201908052210+e60b266~84~ubuntu19.10.1) ...
dpkg: dependency problems prevent configuration of kicad-dbg:
 kicad-dbg depends on kicad (= 5.1.4-201908052210+e60b266~84~ubuntu19.10.1); however:
  Package kicad is not installed.

dpkg: error processing package kicad-dbg (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

I also tried :

sudo aptitude install kicad

and get this :

sudo aptitude install kicad
The following NEW packages will be installed:
  kicad libpng12-0{a} libwxbase3.0-0{a} libwxgtk3.0-0{a} 
The following packages will be REMOVED:
  libboost-context1.62.0{u} libboost-locale1.62.0{u} mint-backgrounds-tessa{u} 
The following partially installed packages will be configured:
0 packages upgraded, 4 newly installed, 3 to remove and 2 not upgraded.
Need to get 10.8 MB of archives. After unpacking 16.2 MB will be freed.
The following packages have unmet dependencies:
 libwxgtk3.0-0v5 : Breaks: libwxgtk3.0-0 but 3.0.2-1+b1 is to be installed
 kicad-dbg : Depends: kicad (= 5.1.4-201908052210+e60b266~84~ubuntu19.10.1) but 0.20140622+bzr4027-3 is to be installed
 libwxbase3.0-0v5 : Breaks: libwxbase3.0-0 but 3.0.2-1+b1 is to be installed
The following actions will resolve these dependencies:

     Remove the following packages:                                 
1)     audacity [1:2.1.3-dmo1+deb9u1 (now, oldstable)]              
2)     kicad-dbg [5.1.4-201908052210+e60b266~84~ubuntu19.10.1 (now)]
3)     libwxbase3.0-0v5 [3.0.2+dfsg-4 (now)]                        
4)     libwxgtk3.0-0v5 [3.0.2+dfsg-4 (now)]                         
5)     pgadmin3 [1.22.2-1 (now)]                                    
6)     playonlinux [4.3.4 (now)]                                    
7)     python-wxgtk3.0 [ (now)]                       

Accept this solution? [Y/n/q/?] ^X^Z
[8]+  Stopped                 sudo aptitude install kicad

so I don’t know to remove what package and why?

this question link via stackexchange:

Thanks for your attention and time.

  1. You shouldn’t have kicad-dbg if you don’t have kicad installed already. It’s safe to do apt purge kicad-dbg.
  2. Mint LMDE is based on Debian so get kicad from buster backports repo, not from ubuntu ppa.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.