Dependecies error installing kicad in bullseye

Hello, sorry for my English and for my light known of linux and kicad.
I have been working without problems with the last version of kicad in Debian Buster but when I upgraded to Bullseye the system remove kicad and I am not able to install again some dependencies are broken.
I have solve partially the issue installing some dependencies from debian repository, but I can not solve the python dependency problem. This is the out when I try “sudo apt install kicad”.

Los siguientes paquetes tienen dependencias incumplidas:
kicad : Depende: libngspice0 (>= 28) pero no va a instalarse
Depende: python3 (< 3.8) pero 3.9.2-3 va a ser instalado
Recomienda: kicad-libraries pero no va a instalarse
Recomienda: kicad-demos pero no va a instalarse
Recomienda: xsltproc pero no es instalable
E: Dependencias incumplidas. Intente «apt --fix-broken install» sin paquetes (o especifique una solución).

I do not know how to continue.

Something odd about the Python 3 dependency as 3.8 went out of full support in May.
Normally it is a >=, not <

Bullseye was an adventure for me. I stopped midway through. I poked around on another computer and came up with this:
aptitude --full-resolver safe-upgrade

I ran it twice to make sure it had completed. Then:|
apt --fix-broken install

Again, I ran that twice to make sure it had completed. Then:
apt autoremove

I rebooted because I could only boot to a kernel 4 shell at that point. Been fine since minus one program that won’t start. Might never. Turns out ricochet-im is abandon ware. :frowning:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.