Default Project Template KiCad 4/5


as I’m on my way to make KiCad 4 and 5 working in parallel, I tried to modify the path to the default project template file

KiCad 4
By default, this is the file /usr/share/kicad/template/
with the default environment variable KICAD_PTEMPLATES=/usr/share/kicad/template/

Now I tried to set the KICAD_PTEMPLATES to a different path, which contains a file, which is explicitly for KiCad 4. But it seems, that the variable only defines, where template projects can be found. KiCad 4 allways looks in that fixed path (/usr/share/kicad/template/ for the default project template, which is not, what I expected.

KiCad 5
With KiCad 5, the situation is the same. As stated in the KiCad blog, the default file must not contain any libraries, when used for KiCad 5: (paragraph 3)

We have here another conflict between the versions 4 and 5.

I’ll report a bug…

1 Like

Until this will be fixed: Using template projects, which are in the path of KICAD_PTEMPLATES

as mentioned by @eelik, there seems to be some progress:

I’m very happy, that my concerns and bugreports are taken seriously. Thats’s my feeling for every bug I’ve reported regarding KiCad 5. Great work!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.