[Debian, PCBnew, SaveAs] Possible bug - Please confirm[Solved]


I’m not sure this is a bug or if it’s intended to be like this but when I try to save a copy of some pcb layout created in pcbnew, it is not accepting the name I try to assign to it. It’s simply saved with “noname.kicad_pcb”.
Can anyone please confirm this? If this is a bug I’ll report it via launchpad!

What version of KiCad?

Sorry. I forgot. Kicad 5.0.0+dfsg1-2~bpo9+1 under Debian Stretch.

Please can anyone make a test to confirm or not this situation? Just a quick test of a couple of people and it might be enough to send a bug report if it confirms!

You have to give the exact steps, “try to save a copy of some pcb layout” isn’t enough. Every step so that they can be repeated with the UI elements.

Well, I just built a small schematic circuit, assigned footprints and generated the pcb layout with pcbnew application. Then I saved as normal and then I wanted to make a new version of the pcb layout and when I tried to go to “File->Save Copy As”, I gave it a name but it didn’t accepted that name I chose. It rather saved it as “noname.kicad_pcb”. That’s it. What else is needed? Please let me know, and I’ll post it!


I have just follow your steps. the name suggested is as you said, noname.kicad_pcb.

I overwrote noname and gave it the name I wanted, let’s say yesname.kicad_pcb. No problem.
A new project called yesname.pro was also created.

Version: 5.0.0-fee4fd1~66~ubuntu14.04.1, release build

1 Like

Ok, thank you!

I don’t know what happened yesterday. I just couldn’t chose the name I wanted. I tested today again and worked with no problem. Sorry.

I think this might be marked as [solved] or [closed].


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.