Debian backports for kicad 5.0.2


#1

I changed my linux distribution yesterday to a different debian stable distribution. When I installed
kicad w/ apt, I got this old version:

Application: KiCad Version: (22-Jun-2014 BZR 4027)-stable Build: wxWidgets 3.0.1 (wchar_t,compiler with C++ ABI 1002,GCC 4.9.1,wx containers,compatible with 2.8) Platform: Linux 3.16.0-7-amd64 x86_64, 64 bit, Little endian, wxGTK Boost version: 1.53.0 Options: USE_PCBNEW_NANOMETRES=ON KICAD_GOST=OFF USE_WX_GRAPHICS_CONTEXT=OFF USE_WX_OVERLAY=OFF KICAD_SCRIPTING=OFF KICAD_SCRIPTING_MODULES=OFF KICAD_SCRIPTING_WXPYTHON=OFF

NOT GOOD! This looks older than kicad 4.0.7.

First, how do I find a debian repository w/ binaries for the lastest kicad 5.0.2 (this is the version I
used for all my kicad projects before I changed linux distribution) built for the amd64 architecture ?

Second, how do I modify my debian repositories to load the new stable kicad using apt or synaptic?

My repositories are currently set as:

$ cat  /etc/apt/sources.list
deb http://repository.solydxk.com/ solydxk-8 main upstream import
deb http://ftp.debian.org/debian jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free

Third, if I install the new kicad will it overwrite the old kicad, or do I have to remove the old
kicad first?


#2

Point 1: There is no kicad 5.0.8, the current version is 5.0.2

You need to manually activate the correct ppa for your system. (The default version in the default repos is indeed very old. Especially for a very old debian.)
Kicad download page with description on how to install for debian: http://kicad-pcb.org/download/debian/


#3

Thank you, Rene_Poschl. I corrected the version no. I don’t know what a ppa is, but will take a look at the URL you posted.


#4

Okay, now I know what a PPA is. Is there an official PPA for kicad 5.0.8?
(I could only find one for 5.0.0 at PPA for KiCad 5) Or a tarball with a make file that I can download and compile using my C compiler, gcc (Debian 4.9.2-10+deb8u2) 4.9.2 ?


#5

For Debian there are no PPA’s available and there is no need for.

But please don’t use Jessie as an start for using a Debian system, it’s simple to old to get a recent KiCad version build on. Make your live easier and use the a Stretch release then instead. There you can install 5.0.2 from the backport repository.


#6

Thanks for the tip, tijuca.


#7

As oF Feb 5, 2019:

possible debian stretch derivative distro’s w/ KDE or KDE Plasma:

QROS 2.6
Netrunner 19.01 1/14/19
Septor Linux Tor 1/19/19
Kali 2018.4
Sparky Linux 4.9 (1/5/19)
Kanotix Steelfire

Did I miss a good one?

I have excluded Ubuntu-based distro’s, mainly because GNOME has never appealed to me in the slightest. However, I admit I haven’t tried
it in the last ten years.

I haven’t tried any of these for a desktop OS. I am using Solydk
on my desktop, which I like very much, but it is a jessie derivative.
Of course there is debian 9 stretch, but I have no confidence in my
skills installing it into a working desktop system.

There is also KDE neon Rebased on Ubuntu 18.04 LTS “Bionic Beaver”
from September 2018, but I have no reason to think it is based on
debian 9 stretch. I think it is an ubuntu derivative.


#8

Okay, I have upgraded to a more recent stable debian 9 stretch operating system and have installed cmake version 3.7.2. I already have gcc (Debian 6.3.0-18+deb9u1) 6.3.0 20170516 I kept a list of the libraries that APT added when I added packages with APT.

Is there an existing stretch .deb package that I can install, so I don’t have to build kicad 5.0.2 from source?

I think the version: 5.0.2+dfsg1-1 listed at https://tracker.debian.org/pkg/kicad I think this is called debian_stable_backports package at the URL Rene_Poschl posted earlier. Am I wrong? Anyway, I see that this package is still early in the development process, nowhere near release.

With #apt install kicad, I keep getting the 4.0.5 package. Is there an existing 5.0.2 deb package that will work on my computer?

Or is building kicad from source in userland a better (more practical) option?

UPDATE: I found specific instructions at https://backports.debian.org
/Instructions/ under Install a package from backports that I followed after first backing up my /etc/apt/sources.list.

Then I successfully installed Version: kicad 5.0.2+dfsg1-1~bpo9+1, release build to my computer. PHEW! No more thoughts about building in userland. At least, not for now.


#9

I suggest to reread Rene’s post from above carefully, especially the link to the KiCad website Rene has given. :wink:


#10

That website didn’t help me, tijuca–probably because this was my first use of a debian backport, and I needed specific, detailed instructions.
Instructions that enabled me to install kicad through a debian backport are at https://backports.debian.org/Instructions/


#11

If you would’ve read on the site just one more paragraph further down you would have found quite the same information by the given link to the Debian wiki about backports.

The backports repositories gives the user the possibility to get newer version with new functions, the stable release will “just” get security updates but no new versions. As KiCad isn’t sensible in that way no updates will go into the stable-security archives.


#12

I have been running Debian Buster for over half a year now and KiCad V5.0.2 is the default for this distribution.

My knowledge about Linux is not too great, but basically I have had no groubles. It just works :slight_smile:

A small exception for some (common?) video codecs. I’ve tried to add them manually but I can’t seem to figure that out.

In the past I’ve been (very slightly) happier with Mint. Mint is more made for end users, while Debian (as I see it) is more a distribution that’s closer to 100% Open Source to make it easier to be used as a base distribution by other distributions.


#13

Debian linux uses a highly-structured way to add software for all users to use. Yes, paulvdh, I use debian-derivative distributions that are redistributions of debian linux optimized to give the first-timer user a good experience. I had used kicad 5.0.8 on Neptune 5.3 OS, released in Nov. 2018. I had some troubles in January 2019. After trying unsuccessfully to solve them, I decided to reinstall the Neptune OS 5.6 and started that last week. Unfortunately, on the second try, it failed to put a working GRUB on my hard drive. I don’t really know anything about GRUB except that if I only use one OS, GRUB should start that OS with no user input. Unfortunately, it failed and dumped the user into some kind of rescue mode which I did not understand. So I installed SolydK, another Debian-derivative distribution w/ KDE Plasma.


#14

The same day I installed it, I learned it was a jessie derivative. I knew a debian stretch-derivative would potentially appear after June 2018, because I had downloaded Debian stretch in June 2017. After searching the SolydK forum and download sites, I found a new SolydK distribution released this month that had not been mentioned on any webpage. (Beware on the web this distro. is called SolydXK because the end-user has the option of installing either KDE OR XFCE.) I burned it onto a DVD and took it for a test ride, verifying it was a debian 9 release. Then I installed it overtop the earlier SolydK installation.

Why do you need to add video codecs? Which applications don’t work?


#15

About the video … I probably should not have mentioned it, as I do not find it important enough to even diagnose the problem. I had problems with playing anything from vimeo, and just now did a test. Turns out it works in Firefox, but not in Opera, but Also some other small things. VLC did not play Wayne Stambaugh’s Fosdem 2019 talk well, but another installed player did it without problem.

If you have a tendency to experiment a lot with distributions, SSD’s have become so cheap lately that you can add a pretty decent SSD for EUR25 to your PC.
Then you can use the Bios/Uefi to select from which drive you start and you can circumvent any trobles with Grub. You can then use one boot SSD for a “known good” distro, and play with grub and other distro’s on the other disk.

A long time ago I started using a separate disk (3TB HDD) for /home and data, and I just mount that with whatever Distro I fancy to play around with. (And makes the above easier). There are some small probblems here. For example if different distro’s use different versions of programs, and after a reboot they get confronted with the configuration file(s) of that other version it messes some things up a bit.


#16

I am able to watch the video at https://fosdem.org/2019/schedule/event/kicad/
just by clicking on it in Firefox ESR, the default browser.