De-laminated PCB board show in 3D viewer


The 3D viewer show my PCB board in de-laminated condition. See the picture showing the edge of my PCB board.

I’m not sure it is software issue or is due to wrong physical stackup setting.

I’m using KICAD 7.0.

Anyone can give me the advise?

Dielectric 1 is very thin with it’s 0.1mm. If you make it a more normal 1.5mm then everything is brought a bit more into proportion.

I think my screenshot below are all defaults.

Where does your stackup come from?
Why is your “Dielectric 1” set to PrePreg? Prepreg is uncured PCB material that is normally used to add extra layers to the core.


My board is a 0.23mm thin PCB. A very small PCB board with 4mm*4mm outline. The stackup is from PCB supplier.
Forgotten to change back to “core” while testing the feature. Show the same in 3D vewer with “core”.

I had tested up with 1.1mm core thickness, the #D viewer still show de-laminated PCB board.


This seems the current state of the 3D viewer and I’m able to reproduce this. It’s just very noticable in your example because of the very unusual geometric settings and therefore very unusual zoom settings in the 3D viewer.
If this disturbs you too much please open a gitlab bug report (don’t forget to provide a example project) and the developers may decide if this needs some countermeasures.

Thanks for your feedback. The 3D viewer just an add-on score to my work. Doesn’t matter if cannot using it.

Could you clarify what “de-laminated” means? What is expected?
check if you have “thickness” option enabled in the settings.

The mask layer is drawn above the copper layer so it looks right when the mask is above copper. Unfortunately that causes it to float when there is no copper below it. Handling that correctly, i.e. splitting the mask layer into two layers one directly on the PCB substrate and one above the copper layer would probably be very computationally expensive (and probably hard to code) for very little benefit?

I could verify that on a 100x160mm PCB the soldermask layer also “floats” above the copper layer, but it is nearly invisible on a PCB of that size (and 1.6mm thickness).

Flowing the soldermask around the copper is probably doable, but not worth the effort.

A compromise could be to render the soldermask thickness as “Soldermask + Copper”, which would result in the copper “embedded” in the soldermask, but still with a flat top.

There is a very very small gap between copper and board, it looks like the copper is “floating” on the board. But for normal boards only very hard to recognize.
I have to zoom and rotate very carefully to see this gap between board body and the copper shapes.

example 10x10mm pcb with bog standard stackup:

Thanks mf_ibfeew for the explanation and conformation. Seem like this is the normal way of 3D viewer rendering the model. The “layers” just become notice-able when work with very thin PCB.