CvPCB unable to Associate component to correct footprint


#1

I am running Kicad 4.0.5 on a Windows 7 64 bit platform. I have created a schematic and the footprints for each of the schematic components.
In the CvPCB tool, when I attempt to associate each component with the correct footprint, I get an CvPcb warning of the format “component : footprint not found in any of the project libraries.”
In the Cvpcb window, I can see the library nickname (which points to the library where I stored the footprint files) in the left column, the component name in the middle column and the “library nickname:footprint name” in the right column.
So I am at a loss as to why I am getting the error message.


#2

Either a configuration or race-condition problem.

Some things to check (without screenshots and more info we’re stabbing in the dark here):

  • Is the footprint saved and the fp editor closed at that point in time?

  • If you view the footprint that doesn’t work via the button in CvPCB - what happens?

  • Can you take a screenshot of the library manager window (global and project specific lib tabs each)

CvPCB>Preferences>Footprint Libraries

  • does the error appear for ANY footprint you’re trying to select or just for ‘special’ ones?

#3

The footprint is saved and the footprint editor are closed.
“View Selected footprint” shows both footprints RG2ET and ARA220A12 when I select each in turn from the middle column.
The Global libraries (which contain Ren_footprints where my two footprints are stored) is attached. The "Project Specific Libraries is empty (I did not use it).


Uploading…
What I have been doing to associate the component to the footptint in Cvpcb is, I select RLY1 in the middle column, and Ren_footprints:RG2ET in the right column, and press the “Perform Automatic Footprint Association” button at the top of the window (see screen shot). This is when I get the error for RLY1 as shown in the screen shot. If I select RLY2 in the middle column and Ren_footprints:ARA220A12 in the right column, and press the “Perform Automatic Footprint Association” button, I still get the error for RLY1.

Uploading…

I only have the two components in my design, and a custom footprint for each as shown.


#4

The only thing that springs to mind for me is that there is somewhere an illegal symbol (letter).
What is the full path to the directory Ren_footprints.pretty (and is it called as i have written on the left?)
Is the footprint called RG2ET.kicad_mod

Can you assign this footprint directly in the symbol?
(press e and edit the footprint field.)

Can you assign other symbols to footprints?
(add a resistor and assign a footprint to it.)
If this works copy the resistor footprint to your library (using the footprint editor)
and try to assign this footprint. Does this work?


#5

Why do you use Perform Automatic Footprint Association in this case?

Did you try to do it this way yet (I thought so)?

  1. select RLY1 in the middle column
  2. double-click on Ren_footprints:RG2ET in the right column

Middle or right column?
We (or better you) are interested in finding if the stuff that is shown in the right column is working and accessible - CvPCB essentially thinks there is no problem, otherwise it wouldn’t show you those footprints.
So to test this do this:

  1. select Ren_footprints:RG2ET in the right column
  2. click on View Selected footprint button

To that error… did you - by any chance - pre-define footprints in your symbol definitions?

Please post a screenshot of the symbol properties of RLY1 from within EEschema, similar to this screenshot (the Browse Footprints button is what @Rene_Poschl means with “Can you assign this footprint directly in the symbol?”):

And yeah, that KIPRJMOD path variable in the library manager screenshot looks suspicious.
Are those spaces in the project folder name?

… \rmaynes\My Documents\RG2ET-L2-H10 INTERPOSER

If you can - and I highly recommend it - store anything that is KiCAD data (projects, local libraries, etc. pp.) in a data_KiCAD folder without spaces or other problematic characters in the path.
Personally I have partitioned my mechanical harddisk in the past into C:[Win], D:[Swap] and E:[Data].
My current config includes an SSD for C: and D:, which means my mechanical drive E: is a single data partition… and that’s also where the Data_KiCAD folder is.
It makes programs happier that have problems with spaces/etc. and I can easily backup the whole E: drive.


#6

I am a first time user, and I had used the footprint association button because it was part of the process described on a web page (not this user group’s). I found that there were different methods out there for associating components to footprints, including editing a Footprints Association File and manually adding them, one per line.
Your solution of double clicking the footprint in the right side column worked.

To answer some of the other questions,
I had defined my own footprints after first completing the schematic using components which I created myself, then annotating them. The footprints (RLY1 and RLY2) were created using the footprint editor. They were both visible in Cvpcb using the view footprints button.

So the root cause of my problem was using the wrong method for associating the components to the footprint.

I am now into the routing part of the design flow. Thank you for your assistance!