cvPcb pin filter (mostly) broken for me?


#1

Hi all: I’ve been using KiCad 4.0.4 for a couple years now and doing my first KiCad 5 project using V5.1.4 under Windows 10. All has been going well with schematic capture until I got to assigning footprints. Very weirdly, the filter by number of pins isn’t working for any library symbols! If I select filter by # of pins, all library symbols disappear, leaving only symbols in my personal library with matching pin counts. With the pins filter off, library symbols are all there. I haven’t (knowingly) messed with any defaults except adding my personal library. I did start with an imported V4.0.4 schematic, so feared it is something from there, but as an experiment I created a schematic from scratch and still get the same issue.

There are some posts about this issue, but they are back in early '18 for what looks like beta builds. Something this fundamental can’t be universally broken, so know it is something unique to me. Any suggestions greatly appreciated. I looked and can’t see any references to this issue outside the above obsolete threads.

will


#2

There are 4 buttons there
image

Make sure you only enable pin filter. Common mistake is to leave the library filter (3rd button) enabled, that way footprints are filtered by library chosen in left column AND pin count.


#3

First of all kicad 4.0.4 is hopelessly outdated… At least update to v4.0.7 and for the love of god switch to v5 as soon as you have your current projects finished. (Befor updating to v5 read: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup to avoid running into problems. Before opening an old project read Converting KiCad version 4 projects to version 5 (Remap a project))


Regarding cvpcb read How can i assign a footprint to a symbol? but be aware that this already uses screenshots of v5 so you will need to be a bit creative with translating it back to v4.


#4

You misread their post.


#5

That means my tutorials are even more relevant


#6

Q1ck: I have tried the library button, but on or off, nothing still shows up except my library. I used that regularly under 4.0.4 to narrow searches when necessary.

Rene_Poschl: OK, will look at the posts. I am using legacy libraries. When I fired up KiCad 5.1.4 the first time with a legacy design, that seemed the right choice, but now I notice that even for a brand new design, the global library list says “legacy” for all libraries. Even that seems a long shot as I’d not be the first person reporting that pin filtering doesn’t work on a legacy library. It is a good starting point though. I’ll poke around and see what I discover.

will

will


#7

SOLVED!!!

In looking over Rene_Poschl’s post there was a step about firing up pcb_new to create the new default library table. I had not yet run V5 pcb_new as this is my first V5 project. I need a netlist to give pcb_new! I ran it, got the dialog about updating tables, accepted the defaults and then went back to eeschema and viola! Pin filtering now works for library parts!

LESSON LEARNED: You need to fire up pcb_new to update the footprint tables before cvpcb can accurately parse the library part info. That is obscure enough that I can see why there haven’t been any previous posts. I wouldn’t have run across it if I had simply fired up pcb_new just to see it ran after upgrading.

I had gone through Rene_Poschi’s suggestion of deleting the ftp-lib-table file in my user directory, but now not sure if that was necessary.

will