CVPCB libraries not the same as PCBNew libraries

Hi All

I’m confused - I thought the libraries listed in the left pane of CVPCB should be the same as the footprint libraries listed in PCBNew, but they’re not. Here’s my procedure:

  1. Open KiCAD - my project is already loaded
  2. Double click on the .sch and Eeschema opens
  3. Click on the CVPCB button in Eeschema
  4. Go Preferences > Footprint Libraries. The “PCB Library Tables” window opens. It shows the table being C:\Users\Danny\AppData\Roaming\kicad\fp-lib-table. The libraries listed are mostly KiCAD type, plus a few Eagle and Legacy.
  5. Back to Eeschema - click on “Run PCBNew…” button. In PCBNew, go Preferences > “Footprint Libraries Manager”. I thought this was the same place as step 4 took me to. It looks the same and the location is the same as in step 4, but the libraries listed are different - they are all KiCAD format - no Eagle or Legacy entries.

Am I misunderstanding something or is there something wrong with my setup?


EDIT: Good spot Joan_Sparky - corrected “cvPCB” to “PCBNew”

Using Win10 x64, KiCAD 4.0.5 release build.

Re 5.
Can you confirm this is a typo?

Personally start EEschema and PCBnew from the KiCAD project manager via their respective buttons for the last couple of months.
I don’t click on any files in the project manager any more.

How does the actual fp-lib-table file look like when you open it with a text editor?

Ok, I’ve tried opening fp

I’ve tried running KiCAD on my laptop and it works fine there - going into PCB Library Tables via CVPCB or via PCBNew both show the same thing - the lists are identical. I should note that the working KICAD folders on my laptop and desktop are sync’d (using Resilio Sync), but that doesn’t include the Roaming folder and therefore “fp-lib-table”, so these are unique to each machine (because I didn’t realise they were held outside of the working folders until now!).

On the desktop I have now edited “PCB Library Tables” by removing almost all libraries when accessed from CVPCB, while when accessed from PCBNew, there are loads of libraries listed. If I make any changes to the version accessed via CVPCB, and then close “PCB Library Tables”, the file “fp-lib-table” is 1kB. If I then open “PCB Library Tables” from PCBNew (which has loads of libraries listed), make a change, and exit “PCB Library Tables”, the file size of “fp-lib-table” jumps to 12kB (and the time-stamp updates in both instances). Basically, it looks to me like they’re reading the table from different places, but writing to the same place i.e. “fp-lib-table”.

Also, at the bottom of the PCB Library Tables window where it shows the Path Substitutions, neither version of PCB Library Tables is showing the KIGITHUB line - there are only three lines in each. Not sure if that’s relevant.

Am I misunderstanding how this is supposed to work or is something odd going on?


it only shows three lines under “Path Substitutions” at the bottom (KIGITHUB is missing), rather than the four lines that are shown when I open it from PCBNew.

Sounds odd. There should only be one actual working fp-lib-table afaik.
And on windows it should be located here:


There is another one located here, but it’s supposed to be a template only

C:\Program Files\KiCad\share\kicad\template\fp-lib-table

I tried editing the template file C:\Program Files\KiCad\share\kicad\template\fp-lib-table and it didn’t affect anything so it isn’t coming from there…

I’ve just realised, I pulled the standard libraries down from Github a few days ago using the “Append with wizard” option in “PCB Library Tables”, and then the “Github repository” radio button - the libraries are just the standard ones from They’re all listed as “KiCad” under “Plugin Type” rather than “Github”. No idea why that might lead to an inconsistency? Maybe because Github isn’t listed under “Path Substitutions” at the bottom of the “PCB Libraries Tables” window?

Actually, only having three “Path Substitutions” rows at the bottom of the “PCB Library Tables” seems odd - my laptop is showing all four rows as are shown under “Configure Paths”. The desktop shows three rows there under “PCB Library Tables”, but four under “Configure Paths”, with the KIGITHUB row being the difference.

I don’t use the github libs, so no experience. I think the Github type would mean that they’re always being taken from the repo, instead of your local drive.
@keruseykaryu will know, or @SchrodingersGat

[quote=“mpdanny, post:5, topic:5133”]
Maybe because Github isn’t listed under “Path Substitutions” at the bottom of the “PCB Libraries Tables” window?[/quote]

The path variable only helps for the fp-lib-table file being easier to maintain, changing the variable content in one place changes it for all entries, intead of having to go through all entries one by one.
Shouldn’t be a problem, unless the file contains {$KIGITHUB} and it’s not defined in your project file I think?

@mpdanny it might be helpful to tell us the values of your KiCad paths (Kicad > Preferences > Configure Paths).

Also the fp-lib-table file? I think you should be able to post that here as an attachment?

I also do not use the Github repo option so I’m not sure if that is going to be the source of the issue.

Here’s the “Configure Paths” options:
KICAD_PTEMPLATES: D:\Work\PCB\KiCAD\share\kicad\template
KISYS3DMOD: D:\Work\PCB\KiCAD\share\kicad\modules\packages3d
KISYSMOD: D:\Work\PCB\KiCAD\share\kicad\modules

The KIGITHUB isn’t listed at the bottom of the “PCB Library Tables” window though. I’ve switched to using the component libraries as “Project Specific Libraries” for now so all is well.

fp-lib-table (10.9 KB)