CVPCB does not see footprints(2)

This may or may not be similar to another post with the same title. I am a noob, and CVPCB seemed to be working until I got to one part for which it stubbornly refuses to display SMD parts that are definitely in the libraries in the table. The attached screen-scrape shows the problem. Unfortunately the highlighting is lost in the process of doing the screen-scrape, so I have put rectangles around the two table entries that are highlighted in CVPCB.
The part in question has no footprint defined in the schematic symbol, so I would expect it to be wide open for me to choose. I think that particular

part is only available in SMD, so it is odd that I am seeing all these through-hole options, but with three SMD ones at the top!
I am completely stuck at this stage. I have tried saving from CVPCB, updating the netlist etc. multiple times with no change. I tried manually editing the symbol in EESCHEMA so that the footprint is ‘SOD-123’, but still nothing shows up in CVPCB. The library containing the part is at the top of my list of libraries in EESCHEMA.

I am using Version:(2015-09-08 BZR 6170, Git 6269158)-product, release build. Win 74, 64 pro.

I guess I have answered my own question. Even though the Footprint field in my symbol was empty when I looked at it inthe library editor, somehow EESCHEMA had added the following to my part:



Apparently it must do this for all diodes if nothing is specified. Probably a setting somewhere??? Or maybe I copied from a part that had them in there? I could not see it from the GUI, it needed an editor.

Anyway, it does this for all diodes, so I simply found them using Notepad++ and deleted everything after $FPLIST and before $ENDFPLIST. Then I can see all the parts!

The lesson is that if things are just not right using the GUI, close everything and take a look at the appropriate files using a text editor- you will often spot what is going on.

I apologize for the bandwidth, but maybe it will help someone. And organizing my thoughts for the post got me un-stuck!

If you can recreate the problem with the original file, could you please try the following? I can see that your footprint filter (the three rightmost icons) is set to filter by keyword. Disable that one, and then enable the rightmost to filter by library. That might solve your problem in a more GUI fashion :wink: I’m guessing that part that you’ve deleted is information regarding automatic footprint filtering, you should be able to find that info easily in the component editor and change it to your requirements, or ditch it altogether.