CvPCB Crashing KiCAD


#1

Hey Guys
I need some assistance using CvPCB.
When I runCvPCB whether in a my project or a blank project it crashes KiCAD with no error. I have generated a net list and tried removing unused libraries and problem is not solved.

I am running windows 10 and KiCAD 4.0.5.

Thanks for your assistance


#2

This seems to be a known problem, https://bugs.launchpad.net/kicad/+bug/1656685 I would encourage you to add your version information to the bug report (Help->Copy Version Information).

Logic suggests it is something to do with loading the libraries, but crash with no message is hard to diagnose unless it can be reproduced in debug mode.


#3

What happens if you open the footprint editor and in there hit the footprint browser button?


#4

“browser” maybe?

Not trying to be a NIT; for a newcomer it might add a little confusion to the mix.


#5

Yeah, to get to the footprint browser most directly and not involving PCBnew in a normal way you go through the footprint editor.
Once you start the browser in there it will try to load the footprint libs.


#6

VERY CLEAR NOW!

Editor, viewer, and there used to be a “browser” (I think).

Anyways, was not trying to be a PITA, just didn’t think your reply was explicitly presented. And, it IS now.


#7

The footprint browser is accessible from pcbnew. The footprint editor is accessible from both pcbnew and the project manager.

Similarly, the schematic symbol browser is accessible from EESchema. The symbol editor is accessible from both EESchema and the project manager.

I do not know why the browsers aren’t available from the project manager.


#8

I’m sure we’ll get there at some point, @c4757p seems to want to work into that direction (my interpretation :slight_smile: )

PS: My point about trying to start the footprint browser as driectly as possible was just to check if the footprint libraries settings are the cause of the observed behavior as he mentions libraries. As he can start EEschema and create netlists I assumed the symbol libs are fine and he referred to the footprint libs.


#9

I think the two terms, “Browser” and “Viewer” should mean two distinctly different things in KiCad.

Viewing, should mean, “LOOKING at local files on the computer.”

Browsing, should mean, “Shopping on-line (AND USING DATA) on GetHub.”


#10

Thanks for all the help. I removed all the footprints that uses GITHUB and added the footprints that were stored locally this seems to be working with much less bugs.