Cvpcb associate footprints


#1

mac osx 10.14.3, latest Kicad finished schematic, annotated, created a net list, performed electrical rules check, generated net list, run cvpcb, centre pain shows net list but no components footprint lists, can’t open library’s, library working ok in Eeschema to generate schematic, mac crashes if i try to make schematic symbols using component library editor


#2

In KiCad the libraries are seperated for footprints and symbols. Meaning it is not necessarily true that everything is setup correctly if you can view schematic symbols.

So can you see footprints when using the footprint editor?

Also please add information about your kicad version. (In the menu bar: help->about->copy version info)

Additionally: If you now run version 5 did you run version 4 in the past? How did you install kicad?


#3

macOS mojave 10.14.3
downloaded from Kicad-pcb.org/download mac os
stable release 5.0,2-5
for macos 10.14:kica (mirror)
i haven’t used version 4 in the past.
I’ve tried to work through the concise guide, however when i got to using component library to create a new part worked until I tried to place pin hit ok the software crashed, tried several times crashed every time, are there any clear and concise instructions available.


#4

You do not need to generate the netlist in v5.
The purpose of the netlist was to communicate connectivity information from eeschema to pcb_new. The new way of doing the same thing is by using the update pcb from schematic tool (found in the tool menu and in version 5.1 it will also be a button in the top toolbar)

The netlist is meaningless without footprint information so you would need to run cvpcb before generating the netlist for this workflow to make any sense at all.

The center pane does not show the netlist. It shows which symbols are part of the schematic (every instance of usage is shown, identified by the reference designator.) with their currently assigned footprints.
There are multiple options why there are no footprints shown. One would be because you do not have footprints installed or not setup correctly. Another more likely is that you did select the wrong filter settings for this symbol to work with your setup.

Do you see any libraries in the leftmost pane? What happens if you use filter by library and deactivate all other filters?

More details see: How can i assign a footprint to a symbol?

elaborate on this please. What do you mean with “open libraries”?

If KiCad crashes repeatedly on a particular action then it might be best to report this over at the bugtracker.
(I am not yet convinced that all of your troubles are related.)

For that one it is really very important to add the version info in the way i requested.


#5

Rene_Poschl

    March 10

pnunn:
finished schematic, annotated, created a net list, performed electrical rules check, generated net list, run cvpcb

  1. The schematic is now finished. We can now create a Netlist file to which we will add the footprint of each component. Click on the Generate netlist icon on the top toolbar. Click on the Generate Netlist button and save under the default file name.

  2. After generating the Netlist file, click on the Run Cvpcb icon on the top toolbar. If a missing file error window pops up, just ignore it and click OK.

  3. Cvpcb allows you to link all the components in your schematic with footprints in the KiCad library. The pane on the center shows all the components used in your schematic. Here select D1. In the pane on the right you have all the available footprints, here scroll down to LED_THT:LED-D5.0mm and double click on it.

  4. It is possible that the pane on the right shows only a selected subgroup of available footprints. This is because KiCad is trying to suggest to you a subset of suitable footprints. Click on the icons , and to enable or disable these filters.


#6

I am not sure i understand what you want to tell me. A tip look on the forum instead of answering per mail. It might be that the formatting of your answer is totally screwed up.


My current guess is that you try to tell us what your tutorial told you. But there is no link provided and there is only a list of 4 elements (That list has some steps in the wrong order for version 4 and some unnecessary steps for version 5. This is what i explained above already so no need to reiterate it.)