Customize Track Clearance for Net Node

When I’m routing a track to a pad within a net, and I want it to have less clearance than the rest of the net, how do I customize that? I know I can edit a pad to have different clearance values, but when I try to route a track to the pad, it still uses the clearance settings for the net, and therefore, I’m unable to make a connection to the pad because it violates the clearance rules I’ve created for that net. Some pads are closer together than my clearance settings, and so it doesn’t allow me to connect a track to them.

Route the tracks as far as they can go. Then change to narrower track stubs which go to the pads. Alternatively just ignore the DRC errors, but take care that the manufacturer’s rules aren’t violated so that they can’t manufacture it or make it more expensive.

This is a problem which cannot be solved “cleanly” in v5.1 and earlier. In the future the upcoming v6 will have ability to define local clearance rules which should solve this problem.

1 Like

Will that work when you are using net classes? Because right now I have to change the net class rules, route the track, and then change them back, and like you said, I have to ignore the DRC warnings for that area. But if I leave the net class settings the way I want them for the rest of the net and try to connect to the smaller pads, it won’t even connect, because the clearance blocks it from making contact.

You can force KiCad to draw tracks with DRC violations with:
Pcbnew / Route / Interactive Router Settings and then:

  • Mode: “Highlight collisions”, which enables:
  • Options: "Allow DRC violations"

There are some workarounds that may work in some situations without DRC errors. For example, it may be possible to modify the footprint to extend pads in such a way tracks can be connected without DRC errors, but such solutions hare highly specific to the situation at hand.

1 Like