Custom paper size forgotten

Hello, I am writing to report an issue I’ve noticed regarding custom paper sizes in PCBNew.

I set my paper size to the minimum custom size 2.54x2.54mm as mentioned by the dialog …

Screen Shot 2022-06-13 at 12.29.00

This works, and the dialog looks like this …

However, every time I re-open my PCB, my custom size is over-written with 99.9998 …

I presume this is a bug. I am using 6.0.5-0, release build

Yes, thats a bug. I have reproduced it also with v6.0.5. There is a different minimum-value for x/y-paper-size in page-settings-dialog (your 2.54mm) and in the pcb-loading-code (apparently 100/100mm). So your change to papersize x/y==2.54/2.54mm gets saved in the pcb-file. But on subsequent loading the x/y-paper-size gets set to 100/100mm again.
The maximum value (==1219mm) is the same in paper-dialog and board-loading-code.

Feel free to write a descriptive issue on gitlab.

Done. Issue #11807

1 Like

Just one hint: use the kicad–>Help–>Report bug option to file an gitlab-issue.
This automatically fills in an issue-template with the required kicad-version (and other details). So the issue doesn’t gets automatically closed because of missing information.

1 Like

Thank you for the tip on bug filing, I just saw the commit for the fix, looks good.

This leads me to wonder, would there be any adverse effects of allowing a 0x0mm custom page size?

For usage context, I usually hide the “Drawing Sheet” as is allowed in the GUI here…

Screen Shot 2022-06-13 at 19.43.16

This is because I prefer to do layout with the origin in the center of the board and the Drawing Sheet is distracting.

From prior forum reading, origins and the layout-sheet-concept overall seem to be recurring topics of debate, so it’s not my intention to bring those up, and I’ve tried using the “Grid Origin” offset in the “Grid Settings”, but since it doesn’t change the coordinates in the GUI, it unfortunately does not help with centered-layout.

Might a possible way to disable the sheet entirely be to allow a custom sheet size of 0x0mm?

Also:
Bug reported at 04:58 and fix committed at 05:59, so 61 minutes later, and this happens quite a lot with KiCad, which I find quite impressive.

Abusing the sheet size in this way is quite hackish. I would prefer to set the sheet size to some regular paper size (A4 in my case) and then add an offset to the drawing sheet itself.

Piotr does not like to use drawing sheets at all, but apparently KiCad defaults to a default sheet if there is no drawing sheet defined at all. Therefore he uses a drawing sheet that only has some mark to indicate (0, 0).

But overall it is a very low priority item, there are currently 1493 open issues on gitlab, and there are still added more new issues then which can be closed. I think the list is growing with about 50 issues per month.

1 Like

You can create your own drawing sheet to fit your needs. There are some template ones included as starting points (look for the templates folder, at KICAD6_TEMPLATE_DIR).
A drawing sheet doesn’t have to contain any visible content at all, kicad will create an empty one for some imports: “empty.kicad_wks”.

This is remarkable indeed. I’ve been enjoying KiCad for a year and half now, and I’ve found both the application and community to be inspiring.

1 Like

Try changing these configurations:

  1. Go to Preferences → Preferences → Origins & Axes and select “Drill/Place file origin”.
  2. On the same dialog, optionally select Y-axis increases UP.
  3. Click Place → Drill/Place file origin and place the origin in the middle of your worksheet.

The preferences are per-user options, and do not modify the board file. The Drill/Place origin is a board attribute and will be used when generating the Gerbers and drill files.

1 Like

Thank you Reece, this is exactly what I was hoping for.
It’s great that it provides a nice visual indication of the origin as well, very clean.

1 Like