Cursor freezing in schematic

I’ve begun to make a transition from EAGLE to KiCad (wasn’t particularly familiar with EAGLE either).

I’ve installed KiCad 4.05 just because it seems there were more tutorials and info available out there than KiCad 5.0 yet.

I’ve encountered an annoying issue of my cursor freezing quite often in schematic. I’ve googled around a bit to resolve this issue. I’ve tried what I could find as recommendations, including DPI settings, to no avail.

I have a workaround where I would just click on my google chrome icon below and then go back to the schematic. I would like to have a permanent solution though if there is one.

You have already ruled out the permanent solution. :wink: Seriously, nobody is gonna take a lot of effort to support 4.0.5. You need to be at 4.0.7. (And more seriously, if you are just starting jump to 5 and save yourself a ton of aggravation in a few months) Maybe your bug fix is in that. Maybe not. But, that is where to start. I can’t imagine any real positive info out there saying .5 is better than a less buggy .7.


Been there. Was confused also. You found the workaround I used. Click away to something else and come back and it will work again. Weird loss of focus.

The permanent solution for me was to upgrade to V5. Problem solved.

If you’re just starting, I would highly recommend V5 as it has a much better way of handling symbols, footprints, and 3D models. Other than that, most of the V4 tutorials are applicable to V5.

1 Like

Firstly you should always say what your OS is, As you mention Chrome, I suspect Windows of some type.

As a new user I agree with @Mikerowave that you might as well start off with V5 and save yourself the inevitable headache of upgrading to V5 later.
V5 supports import from Eagle projects much better than V4 did.

This forum is run by volunteeers and almost all of them will be running V5 themselves now, so it gets hard to answer V4 questions.

When you go to update, because you’ve already had v4.x on your system, check out this FAQ entry and the linked post. The update process won’t update some of the settings which will cause you problems.

Hopefully the information should help you upgrade with limited effort.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.