Cursor and Crosshair do not match when zooming

Hi there,
i just noticed that on my current Fedora installation my mouse cursor and the cross hair do not snap together. This results in very inconvenient zooming. The picture shows my cursor and the crosshair after zooming out.

This happens in both the schematic and pcb editor.
I found this thread: Cross-hair and mouse cursor are not snapped together after hotkey is pressed
and tried the suggestions there, but no luck. Can anyone help me out?
Thanks in advance

Application: KiCad Schematic Editor

Version: 6.0.4-1.fc35, release build

wxWidgets 3.0.5
libcurl/7.79.1 OpenSSL/1.1.1n-fips zlib/1.2.11 brotli/1.0.9 libidn2/2.3.2 libpsl/0.21.1 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.45.1 OpenLDAP/2.4.59

Platform: Linux 5.16.18-200.fc35.x86_64 x86_64, 64 bit, Little endian, wxGTK, gnome, wayland

Build Info:
Date: Mar 19 2022 00:00:00
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.79.1
ngspice: 36
Compiler: GCC 11.2.1 with C++ ABI 1016

Build settings:

I think this is common on certain high dpi display scales. Do you have a high dpi monitor?

Found it :slight_smile:
Unchecked this option " Center and warp cursor on zoom". It seems to be a “feature” of Kicad.

I do find the “Center and warp cursor on zoom” a useful feature, although it did take some time get used to, but now I wish other programs also worked this way.

And while I do have this feature on, both the cross hair and the mouse arrow are kept together during zooming. During movement, the cross-hair has a slight lag (just like the “trailing mouse cursor” from the '90-ies) but this has not bothered me yet.

The base-height of the text of your screenshots is 9 pixels, so apparently you do not have hi-dpi settings.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.