Crosshair cursor is "sticking"


#1

Hi,
I have a problem with the crosshair cursor in PCBNew. Sometimes, probably when manipulating the zones it “sticks” and does not move along with the mouse cursor.

as is shown on the picture. After randomly clicking on different parts, zones etc. the crosshair “unsticks” and gets its normal position on the edge of the mouse cursor.
The problem is persistent in many nightly builds (I even forgot which was the last version without this bug).

My KiCAD version:

Application: kicad
Version: no-vcs-found-3ed106f~61~ubuntu14.04.1, release build
Libraries:
wxWidgets 3.0.2
libcurl/7.35.0 OpenSSL/1.0.1f zlib/1.2.8 libidn/1.28 librtmp/2.3
Platform: Linux 3.19.0-32-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.54.0
Curl: 7.35.0
Compiler: GCC 4.8.4 with C++ ABI 1002

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_SPICE=ON


#2

Are you in legacy (default) or open gl canvas?
In legacy i think the cursor jumps between grid points. (only “allowed” on the grid) So if you have a large grid (like it seems in your screenshot) you might get the feeling that the cursor sticks at one place.
So to test this simply reduce the grid spacing or move a bit farther towards the next grid point.

Switching between canvases is done in the view menu. (open gl canvas has more features. But also a bit different workflow.)


#3

OpenGL canvas. I know how to switch between them and will try if the problem is persistent in the legacy canvas too.
When I say “sticking” it means that crosshair stays when it is but you can move the mouse pointer, to move parts, to route tracks etc. The only problem is that crosshair is the center point for zoom and when you raise/lower magnification it always is done with the crosshair as a center (which is annoying).
BTW, I’ve just made a test - sticking is not cured with changing the grid size. And one more thing - probably it has something with deleting the zone’s corners (not 100% sure if this is the only reason though).
And one more thing - changing the canvas does not unstick it - I did F9/F11 and it is still stuck. Well, in legacy it is moving freely but when return to OpenGL it stays where was and does not move.

EDIT: Definitely when removing the zone’s corner the crosshair stuck.


#4

I have also experienced this on the Windows Sept 19 nightly in OpenGL mode. I is very early in a project so no zones defined. I really could not figure out what triggered it, seems to happen quite randomly/occasionally after clicking on/selecting something in the field, but I am not sure. The crosshair then also seems to become bigger, but I guess it depends on the amount of zoom. I had to close Pcbnew to make it go away.

Application: kicad
Version: (2017-09-19 revision dddaa7e69)-makepkg, release build
Libraries:
wxWidgets 3.0.3
libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.60.0
Curl: 7.54.1
Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_SPICE=ON


#5

I have never experienced this in Windoze; however, have not yet tried the 19SEP17 nightly build.

In EVERY Windoze build that I have tried, there has always been a bug where the “grid” seems to move in OGL. I frequently have to hit F9 then F11 to get the OGL “grid” back to normal. I suspect that this is because I’ve been using Imperial grids and units; I’ve never seen the problem occur when I do use metric grids and units.

@otoien are you using metric or imperial grids and units?


#6

I am using metric units, but the grid sizes have been set to imperial steps. I did however just discover that there are metric steps down the list.

With respect to grid origin, I have on occasions noticed that it got spontaneously set to a location within my work area. I believe I have on those occasions not touched the grid origin symbol; I just discovered how it is set and can be reset. Looking up the hotkeys I found out why this accidentally happens: I am used to save work in windows applications with Alt-F S, but in KiCad S would set the grid origin. Alt-F does not appear to do anything in KiCad, the menus must be accessed with the mouse.