Creating more than one copper pour for split board

Hi Guys,

I’m a recent convert to KiCad having used Eagle for ages.

I’m creating a PCB with an optional snap-off heatsink so I’ve treated it as a panel with trenches and mousebites to separate them. Trouble is, the copper pour will only cover the side with the components and if I make a new, separate zone, it doesn’t fill. I’m sure Eagle filled each new polygon without problems. Any ideas?

Filled zones without any connections to them are not filled.

For more details:

Surely the copper pour needs to be in contact with the component it is heatsinking?

Anyway, a workaround is to place a single pin module connected to the appropriate net. I put these in the schematic so they don’t get lost.

I like the idea though. I would drop a lot of vias to improve conduction between front and back (assuming there is a bottom layer).

That was the idea. I’m just experimenting with adding an SMD component with both ends connected to GNDPWR which is the net the pour is on. I will add vias if I can get it to work, certainly.

Well, that was partially successful. I made a single pad SMD component with one pin and connected it to ground. Made the local clearance ‘none’ and I get a pour in the heatsink area. Odd though, the 3D preview shows it up. I’ll work on it some more later. Thanks guys.

Check the pad settings of that footprint, surely it has got solder mask and paste activated, which would explain what you see in 3D.

I disabled the masks in the properties:

I really don’t mind if it’s just a display anomaly but, as said, it is meant to be a heat sink so the pour needs to be there.

GNDPAD G1 should not be there. This is not the way.

I maybe have not understood everything you need, but I guess you need a zone for the LM7805 heat sink.
The hole of the LM7805 is the pin that must be attached to the zone. Is this pin connected to the GND net?

In your first picture, the upper zone is not filled. This is the right behaviour. Why? Because if it is filled, that zone will be an island not connected to GND. Kicad doesn’t know the 7805 hole pin (let’s call it pin 4) is internally connected to pin 2 (GND).

An easy workaround: make a new net (for example GND1) for pin 4 in the schematic and a new zone form the trenches attached to GND1. It will also assure the heat sink touches pin 4.

Ah Pedro, I didn’t think of making a custom component. Good idea. No, the top image is just the board without the fill, then next one down filled and finally, the 3D view. However, I think a custom component with a GND pin is a good idea. Many thanks.

It’s definitely neater but still shows up on the 3D View.

May you send us a picture with the 7805 footprint you are using? Or the footprint itself. There is something weird in it.

Yes, I customised the footprint with an added GND pad.

As you said, this allows the pour to cover the snap-off part of the board. I’ll be adding the back side copper pad too.

Ok. The footprint is the problem, not the zone filling!!!

I suppose you’ll bend the 7805 pins son its back sits on the pcb. But now the area will be covered with solder mask and will not make contact.

Make pin 4 this way:
Remove the yellow current hole
Pad type: Through-hole
Shape: Rectangular
SizeX and size Y covering the whole rectangle of the 7805 back.

Shape: circular hole
SizeX: what you need for the big yellow hole
Copper: F.Cu

1 Like

Doh! How could I miss that :slight_smile: Cheers Pedro. I’ll redo the footprint later, when I have a chance and post the result.


Thanks Pedro - Cracked it:

It’s like this on the back and front. Slightly offset across the board but that’s because of my component placement.